summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD58
-rw-r--r--dbus-dontclose.patch22
-rw-r--r--glib.patch74
-rw-r--r--goption.patch91
-rw-r--r--gtksourceview.patch15
-rw-r--r--screem-site-init.patch11
-rw-r--r--screem.install24
8 files changed, 334 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..784ab459cde6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = screem
+ pkgdesc = A source oriented web site development environment for GNOME
+ pkgver = 0.16.1
+ pkgrel = 1
+ url = http://www.screem.org
+ install = screem.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = pkgconfig
+ depends = gtk2
+ depends = libgnome
+ depends = gtksourceview
+ depends = libgtkhtml
+ depends = libgnomeui
+ depends = libcroco
+ depends = libgnomeprintui
+ depends = startup-notification
+ depends = enchant1.6
+ depends = gnome-menus2
+ depends = rarian
+ depends = desktop-file-utils
+ options = !libtool
+ source = http://downloads.sourceforge.net/sourceforge/screem/screem-0.16.1.tar.gz
+ source = goption.patch
+ source = dbus-dontclose.patch
+ source = glib.patch
+ source = gtksourceview.patch
+ source = screem-site-init.patch
+ md5sums = 88bfc0afadb905ddbed9bdfbc869602a
+ md5sums = d8f855a89a6f1479085cd88956d773c1
+ md5sums = 2a26231fbab056165d84bad03dfb3edd
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = screem
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec9d5fe32ad2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Mantainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+# Contributor: Roberto Carvajal <roberto@archlinux.org>
+# Contributor: Kritoke <typeolinux@yahoo.com>
+
+pkgname=screem
+pkgver=0.16.1
+pkgrel=1
+pkgdesc="A source oriented web site development environment for GNOME"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.screem.org"
+depends=('gtk2' 'libgnome' 'gtksourceview' 'libgtkhtml' 'libgnomeui' 'libcroco' \
+ 'libgnomeprintui' 'startup-notification' 'enchant1.6' 'gnome-menus2' 'rarian' \
+ 'desktop-file-utils')
+makedepends=('intltool' 'pkgconfig')
+options=('!libtool')
+install=screem.install
+source=(http://downloads.sourceforge.net/sourceforge/screem/screem-${pkgver}.tar.gz
+ goption.patch
+ dbus-dontclose.patch
+ glib.patch
+ gtksourceview.patch
+ screem-site-init.patch)
+md5sums=('88bfc0afadb905ddbed9bdfbc869602a'
+ 'd8f855a89a6f1479085cd88956d773c1'
+ '2a26231fbab056165d84bad03dfb3edd'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np0 -i "${srcdir}/goption.patch" || return 1
+ patch -Np1 -i "${srcdir}/dbus-dontclose.patch" || return 1
+ patch -p0 -i "${srcdir}/glib.patch"
+ patch -p0 -i "${srcdir}/gtksourceview.patch"
+ patch -p0 -i "${srcdir}/screem-site-init.patch"
+
+ sed -e 's/-DGNOME_DISABLE_DEPRECATED//g' \
+ -e 's/-DGNOMEUI_DISABLE_DEPRECATED//g' \
+ -e 's/-DGTK_DISABLE_DEPRECATED//g' \
+ -i configure || return 1
+
+ LIBS="-lm" ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-update-mime \
+ --disable-update-desktop \
+ --enable-dbus \
+ --enable-enchant=no \
+ --disable-schemas-install || return 1
+ make || return 1
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
+ DESTDIR="${pkgdir}" install || return 1
+
+ install -m755 -d "${pkgdir}/usr/share/gconf/schemas"
+ gconf-merge-schema ${pkgdir}/usr/share/gconf/schemas/${pkgname}.schemas --domain screem ${pkgdir}/etc/gconf/schemas/*.schemas || return 1
+ rm -f ${pkgdir}/etc/gconf/schemas/*.schemas
+}
diff --git a/dbus-dontclose.patch b/dbus-dontclose.patch
new file mode 100644
index 000000000000..45507c57d52c
--- /dev/null
+++ b/dbus-dontclose.patch
@@ -0,0 +1,22 @@
+--- screem-0.16.1/src/screem-dbus.c.orig 2007-03-24 16:11:20.000000000 +0000
++++ screem-0.16.1/src/screem-dbus.c 2007-03-24 16:21:33.000000000 +0000
+@@ -129,19 +129,9 @@ static void screem_dbus_finalize( GObjec
+
+ #ifdef HAVE_DBUS
+ if( priv->conn ) {
+-#if DBUS_VERSION > 33000
+- dbus_connection_close( priv->conn );
+-#else
+- dbus_connection_disconnect( priv->conn );
+-#endif
+ dbus_connection_unref( priv->conn );
+ }
+ if( priv->sconn ) {
+-#if DBUS_VERSION > 33000
+- dbus_connection_close( priv->sconn );
+-#else
+- dbus_connection_disconnect( priv->sconn );
+-#endif
+ dbus_connection_unref( priv->sconn );
+ }
+ #endif
diff --git a/glib.patch b/glib.patch
new file mode 100644
index 000000000000..978d454054b4
--- /dev/null
+++ b/glib.patch
@@ -0,0 +1,74 @@
+--- src/screem-cvs.c 2005-11-05 16:42:13.000000000 +0100
++++ src/screem-cvs.c 2018-12-21 02:33:04.555493450 +0100
+@@ -21,7 +21,7 @@
+ * about box under the help menu for a contact address
+ */
+
+-#include <glib/gutils.h>
++#include <glib.h>
+ #include <stdio.h>
+
+ #include <string.h>
+
+--- src/screem-file-browser.c 2005-11-16 00:02:15.000000000 +0100
++++ src/screem-file-browser.c 2018-12-21 03:00:48.834408443 +0100
+@@ -25,9 +25,7 @@
+
+ #include <config.h>
+
+-#include <glib/gutils.h>
+-#include <glib/ghash.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+
+ #include <libgnomevfs/gnome-vfs-mime-handlers.h>
+ #include <libgnomevfs/gnome-vfs-mime-utils.h>
+
+--- src/screem-site-parse.c 2005-07-29 21:34:59.000000000 +0200
++++ src/screem-site-parse.c 2018-12-21 03:05:26.019857516 +0100
+@@ -1,7 +1,6 @@
+ #include <config.h>
+
+-#include <glib/gmarkup.h>
+-#include <glib/gstrfuncs.h>
++#include <glib.h>
+ #include <string.h>
+
+ #include "fileops.h"
+
+--- src/screem-site-ui.c 2005-11-05 16:08:13.000000000 +0100
++++ src/screem-site-ui.c 2018-12-21 03:12:20.993371176 +0100
+@@ -24,7 +24,7 @@
+
+ #include <config.h>
+
+-#include <glib/gfileutils.h>
++#include <glib.h>
+
+ #include <gtk/gtktogglebutton.h>
+
+--- src/screem-site.c 2005-11-12 20:34:35.000000000 +0100
++++ src/screem-site.c 2018-12-21 03:16:21.864242285 +0100
+@@ -32,8 +32,7 @@
+ #include <unistd.h>
+ #include <dirent.h>
+
+-#include <glib/gfileutils.h>
+-#include <glib/gi18n.h>
++#include <glib.h>
+ #include <libgnome/gnome-exec.h>
+
+ #include <libgnomevfs/gnome-vfs-mime-handlers.h>
+
+--- src/fileops.c 2005-11-12 20:26:14.000000000 +0100
++++ src/fileops.c 2018-12-21 03:20:04.949350046 +0100
+@@ -29,7 +29,7 @@
+ #include <stdio.h>
+ #include <string.h>
+
+-#include <glib/gfileutils.h>
++#include <glib.h>
+
+ #include <gtk/gtkdialog.h>
+ #include <gtk/gtklabel.h>
+
diff --git a/goption.patch b/goption.patch
new file mode 100644
index 000000000000..f0e8f8c5e19d
--- /dev/null
+++ b/goption.patch
@@ -0,0 +1,91 @@
+--- src/screem-main.c 2006-04-17 00:25:57.000000000 +0100
++++ src/screem-main.c 2006-04-17 01:12:35.000000000 +0100
+@@ -54,12 +54,23 @@
+ static gchar *session_filename = SESSION_LAST;
+
+ /* passed parameters stuff */
++#ifndef GNOME_PARAM_GOPTION_CONTEXT
+ static const struct poptOption options[] = {
+ { "load-session", 'l', POPT_ARG_STRING, &session_filename, 0,
+ N_("Load the given session file"),
+ N_("FILE") },
+ { NULL, '\0', 0, NULL, 0, NULL, NULL }
+ };
++#else /* USE GOption interface */
++static const gchar **remaining_args = NULL;
++static GOptionEntry option_entries[] = {
++ { "load-session", 'l', 0, G_OPTION_ARG_STRING, &(session_filename),
++ N_("Load the given session file"), N_("FILE") },
++ { G_OPTION_REMAINING, 0, 0, G_OPTION_ARG_FILENAME_ARRAY, &remaining_args,
++ "Special option that collects any remaining arguments for us" },
++ { NULL }
++};
++#endif
+
+ typedef enum {
+ MISSING_GLADE,
+@@ -75,8 +86,10 @@
+ int main( int argc, char *argv[] )
+ {
+ GnomeProgram *program;
++ const gchar** start_files;
++#ifndef GNOME_PARAM_GOPTION_CONTEXT
+ poptContext ctx;
+- const gchar** start_files;
++#endif
+ const gchar *icon;
+
+ gchar *dotdir;
+@@ -88,11 +101,21 @@
+ bind_textdomain_codeset( GETTEXT_PACKAGE, "UTF-8" );
+ textdomain( GETTEXT_PACKAGE );
+ #endif
++
++#ifdef GNOME_PARAM_GOPTION_CONTEXT
++ GOptionContext *option_context = g_option_context_new("screem");
++ g_option_context_add_main_entries(option_context, option_entries, NULL);
++#endif
++
+ program = gnome_program_init( PACKAGE, VERSION,
+ LIBGNOMEUI_MODULE,
+ argc, argv,
+ GNOME_PROGRAM_STANDARD_PROPERTIES,
++#ifndef GNOME_PARAM_GOPTION_CONTEXT
+ GNOME_PARAM_POPT_TABLE, options,
++#else
++ GNOME_PARAM_GOPTION_CONTEXT, option_context,
++#endif
+ GNOME_PARAM_APP_DATADIR, DATADIR,
+ LIBGNOMEUI_PARAM_DEFAULT_ICON,
+ DATADIR"/pixmaps/screem.png",
+@@ -105,10 +128,14 @@
+ icon = DATADIR"/pixmaps/screem.png";
+ gtk_window_set_default_icon_from_file( icon, NULL );
+
++#ifndef GNOME_PARAM_GOPTION_CONTEXT
+ /* parse arguments */
+ g_object_get( G_OBJECT( program ),
+ GNOME_PARAM_POPT_CONTEXT, &ctx, NULL );
+ start_files = parse_args( ctx, argc, argv );
++#else
++ start_files = remaining_args;
++#endif
+
+ gnome_vfs_init();
+ gnome_authentication_manager_init();
+@@ -160,6 +187,7 @@
+ return FALSE;
+ }
+
++#ifndef GNOME_PARAM_GOPTION_CONTEXT
+ static const gchar **parse_args( poptContext ctx, int argc, char *argv[] )
+ {
+ const gchar** start_files;
+@@ -169,6 +197,7 @@
+
+ return start_files;
+ }
++#endif
+
+ static void screem_main_missing( MissingType type )
+ {
diff --git a/gtksourceview.patch b/gtksourceview.patch
new file mode 100644
index 000000000000..8f1a5fda1150
--- /dev/null
+++ b/gtksourceview.patch
@@ -0,0 +1,15 @@
+--- src/screem-editor.c 2005-11-12 20:21:33.000000000 +0100
++++ src/screem-editor.c 2018-12-21 02:41:40.976012503 +0100
+@@ -36,9 +36,9 @@
+ #include <stdlib.h>
+ #include <string.h>
+
+-#include <gtksourceview/gtksourceview.h>
+-#include <gtksourceview/gtksourcebuffer.h>
+-#include <gtksourceview/gtksourceprintjob.h>
++#include <gtksourceview-1.0/gtksourceview/gtksourceview.h>
++#include <gtksourceview-1.0/gtksourceview/gtksourcebuffer.h>
++#include <gtksourceview-1.0/gtksourceview/gtksourceprintjob.h>
+ #include <gtk/gtk.h>
+
+ #include <gdk/gdkkeysyms.h>
diff --git a/screem-site-init.patch b/screem-site-init.patch
new file mode 100644
index 000000000000..fb2a256e86d3
--- /dev/null
+++ b/screem-site-init.patch
@@ -0,0 +1,11 @@
+--- src/screem-site.c 2018-12-21 03:41:59.267062174 +0100
++++ src/screem-site.c 2018-12-21 03:47:31.918945358 +0100
+@@ -1759,7 +1759,7 @@
+
+ /* all new sites are fake ones, we change this when we
+ load / create a site */
+- screem_site_set_name( site, _("Individual Files") );
++ screem_site_set_name( site, "Individual Files" );
+
+ screem_site_model_initialise( site );
+
diff --git a/screem.install b/screem.install
new file mode 100644
index 000000000000..a3276032d9e5
--- /dev/null
+++ b/screem.install
@@ -0,0 +1,24 @@
+pkgname=screem
+
+post_install() {
+ gconfpkg --install ${pkgname}
+ update-desktop-database -q
+ update-mime-database usr/share/mime > /dev/null
+}
+
+pre_upgrade() {
+ pre_remove $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ gconfpkg --uninstall ${pkgname}
+}
+
+post_remove() {
+ update-desktop-database -q
+ update-mime-database usr/share/mime > /dev/null
+}