summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f7abe63cca6..75971d30de85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,18 @@
pkgbase = screengrab-git
pkgdesc = Crossplatform tool for grabbing screenshots of your desktop.
- pkgver = 2.6.0.15.g896ccd7
+ pkgver = 2.8.0.r1.g400be37
pkgrel = 1
url = https://github.com/lxqt/screengrab
arch = i686
arch = x86_64
- license = GPL2
+ license = GPL-2.0-only
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
- depends = qt5-base
- depends = qt5-x11extras
- depends = kwindowsystem5
+ makedepends = qt6-tools
+ depends = kwindowsystem
depends = libqtxdg-git
- depends = libx11
- depends = libxcb
depends = hicolor-icon-theme
- provides = screengrab=2.6.0.15.g896ccd7
+ provides = screengrab=2.8.0.r1.g400be37
conflicts = screengrab
source = git+https://github.com/lxqt/screengrab
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9ca10f6a2641..e12c7adab44e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Jerome Leclanche <jerome@leclan.ch>
-# Co-Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Co-Maintainer: Peter Mattern <pmattern at arcor dot de>
+# Contributor: Jerome Leclanche <jerome@leclan.ch>
_pkgname=screengrab
pkgname=$_pkgname-git
-pkgver=2.6.0.15.g896ccd7
+pkgver=2.8.0.r1.g400be37
pkgrel=1
pkgdesc="Crossplatform tool for grabbing screenshots of your desktop."
arch=("i686" "x86_64")
url="https://github.com/lxqt/screengrab"
-license=("GPL2")
-depends=("qt5-base" "qt5-x11extras" "kwindowsystem5" "libqtxdg-git" "libx11" "libxcb" "hicolor-icon-theme")
-makedepends=("git" "cmake" "qt5-tools")
+license=("GPL-2.0-only")
+depends=('kwindowsystem' 'libqtxdg-git' 'hicolor-icon-theme')
+makedepends=('git' 'cmake' 'qt6-tools')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("git+https://github.com/lxqt/$_pkgname")
sha256sums=('SKIP')
-
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --always | sed "s/-/./g"
+ git describe --always | sed "s/-/.r/;s/-/./"
}
build() {