summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
-rw-r--r--icu_fix.patch9
3 files changed, 28 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa1e812876a5..ce2a9017157c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Nov 12 20:18:50 UTC 2017
+# Sun Apr 1 05:51:54 UTC 2018
pkgbase = scribus-indigo-git
pkgdesc = A desktop publishing program - indigo fork
pkgver = r108.13622cd
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/nitramr/scribus-indigo/wiki
arch = i686
arch = x86_64
@@ -31,7 +31,9 @@ pkgbase = scribus-indigo-git
provides = scribus
conflicts = scribus
source = git+https://github.com/nitramr/scribus-indigo.git
+ source = icu_fix.patch
md5sums = SKIP
+ md5sums = 90b5e597dc5723a659048b288a6680b0
pkgname = scribus-indigo-git
diff --git a/PKGBUILD b/PKGBUILD
index f14dce5fe78c..55ebbb7850ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=scribus-indigo-git
pkgver=r108.13622cd
-pkgrel=1
+pkgrel=2
pkgdesc="A desktop publishing program - indigo fork"
arch=('i686' 'x86_64')
depends=('hunspell' 'podofo' 'python2' 'libcups' 'graphicsmagick' 'hicolor-icon-theme'
@@ -12,8 +12,9 @@ license=('GPL' 'LGPL')
makedepends=('git' 'cmake' 'qt5-tools' 'dos2unix')
provides=('scribus')
conflicts=('scribus')
-source=("git+https://github.com/nitramr/scribus-indigo.git")
-md5sums=('SKIP')
+source=("git+https://github.com/nitramr/scribus-indigo.git" icu_fix.patch)
+md5sums=('SKIP'
+ '90b5e597dc5723a659048b288a6680b0')
_gitname=scribus-indigo
pkgver() {
@@ -25,17 +26,19 @@ prepare() {
cd "$_gitname"/scribus/plugins/scriptplugin
dos2unix scripts/Ligatursatz.py
find . -type f -name "*.py" -exec sed -i '1s+python$+python2+' {} \;
+ cd "$srcdir"/$_gitname
+ patch -Np0 < "$srcdir"/icu_fix.patch || true
}
build() {
cd "$_gitname"
cmake . -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DCMAKE_SKIP_RPATH:BOOL=YES -DWANT_GRAPHICSMAGICK=1 \
- -DCMAKE_LIBRARY_PATH=/usr/lib \
- -DCMAKE_INCLUDE_PATH=/usr/include/python2.7 \
- -DCMAKE_EXE_LINKER_FLAGS="-lQt5Quick -lQt5PrintSupport" \
- -DCMAKE_APPDATA_DIR=/usr/share/appdata \
- -DQT_PREFIX="/usr"
+ -DCMAKE_SKIP_RPATH:BOOL=YES -DWANT_GRAPHICSMAGICK:BOOL=YES \
+ -DCMAKE_LIBRARY_PATH:PATH=/usr/lib \
+ -DCMAKE_INCLUDE_PATH:PATH=/usr/include/python2.7 \
+ -DCMAKE_EXE_LINKER_FLAGS:STRING="-lQt5Quick -lQt5PrintSupport" \
+ -DCMAKE_APPDATA_DIR:PATH==/usr/share/appdata \
+ -DQT_PREFIX:PATH="/usr"
make
}
@@ -43,7 +46,7 @@ package () {
cd "$_gitname"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
- install -Dm644 scribus.desktop $pkgdir/usr/share/applications/scribus.desktop
- install -d "${pkgdir}"/usr/share/pixmaps
- ln -s /usr/share/scribus/icons/1_5_0/scribus.png "${pkgdir}"/usr/share/pixmaps/scribus.png
+ install -Dm644 scribus.desktop "$pkgdir"/usr/share/applications/scribus.desktop
+ install -d "$pkgdir"/usr/share/pixmaps
+ ln -s /usr/share/scribus/icons/1_5_0/scribus.png "$pkgdir"/usr/share/pixmaps/scribus.png
}
diff --git a/icu_fix.patch b/icu_fix.patch
new file mode 100644
index 000000000000..4a44385223ef
--- /dev/null
+++ b/icu_fix.patch
@@ -0,0 +1,9 @@
+--- CMakeLists.txt (revision 22461)
++++ CMakeLists.txt (working copy)
+@@ -926,5 +926,6 @@
+ # CTL support
+ pkg_check_modules(HARFBUZZ REQUIRED harfbuzz>=0.9.42 harfbuzz-icu)
+ pkg_check_modules(ICU REQUIRED icu-uc)
++add_definitions(-DU_USING_ICU_NAMESPACE=1)
+
+