summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cd6ce9463d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sddm-theme-clairvoyance
+ pkgdesc = An SDDM theme by Ellis Kesterton
+ pkgver = 1.0+1+fb02103
+ pkgrel = 1
+ url = https://github.com/Eayu/sddm-theme-clairvoyance
+ arch = any
+ license = CC-BY-SA
+ makedepends = git
+ makedepends = tar
+ depends = sddm
+ depends = ttf-fira-mono
+ source = git+https://github.com/Eayu/sddm-theme-clairvoyance.git#commit=fb0210303f67325162a5f132b6a3f709dcd8e181
+ sha256sums = SKIP
+
+pkgname = sddm-theme-clairvoyance
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c24a21460b0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+_gitcommit=fb0210303f67325162a5f132b6a3f709dcd8e181
+
+pkgname=sddm-theme-clairvoyance
+pkgver=1.0+1+fb02103
+pkgrel=1
+pkgdesc="An SDDM theme by Ellis Kesterton"
+arch=('any')
+url="https://github.com/Eayu/sddm-theme-clairvoyance"
+license=('CC-BY-SA')
+depends=('sddm' 'ttf-fira-mono')
+makedepends=('git' 'tar')
+source=("git+${url}.git#commit=${_gitcommit}")
+sha256sums=('SKIP')
+
+package() {
+ # cd "${srcdir}/${pkgname}"
+ # install -d "${pkgdir}/usr/share/sddm/themes/"
+ # git archive master --prefix="clairvoyance/" | tar -x -C "${pkgdir}/usr/share/sddm/themes/"
+ # rm -rf "${pkgdir}/usr/share/sddm/themes/clairvoyance/.gitignore"
+
+ cd "${srcdir}"
+ install -d "${pkgdir}/usr/share/sddm/themes/"
+ cp -r "${pkgname}" "${pkgdir}/usr/share/sddm/themes/clairvoyance"
+ rm -rf "${pkgdir}/usr/share/sddm/themes/clairvoyance/.git"
+ rm -rf "${pkgdir}/usr/share/sddm/themes/clairvoyance/.gitignore"
+}