summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--Makefile.inc.patch17
-rw-r--r--PKGBUILD34
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae2b3a592d80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sdf3
+ pkgdesc = Tool for generating, analyzing, transforming, and visualizing random Synchronous DataFlow Graphs (SDFGs)
+ pkgver = latest
+ pkgrel = 1
+ url = http://www.es.ele.tue.nl/sdf3
+ arch = i386
+ arch = x86_64
+ license = GPL
+ makedepends = chrpath
+ makedepends = unzip
+ depends = boost-libs
+ depends = libxml2
+ noextract = sdf3.zip
+ options = !makeflags
+ source = http://www.es.ele.tue.nl/sdf3/download/files/releases/sdf3.zip
+ source = Makefile.inc.patch
+ md5sums = 77eadba886cf8c02b7c6831bd62cb675
+ md5sums = 0607b3b91e382beeb452c0fbfee0e768
+
+pkgname = sdf3
+
diff --git a/Makefile.inc.patch b/Makefile.inc.patch
new file mode 100644
index 000000000000..00675fc3c571
--- /dev/null
+++ b/Makefile.inc.patch
@@ -0,0 +1,17 @@
+diff -ura sdf3/etc/Makefile.inc sdf3.new/etc/Makefile.inc
+--- sdf3/etc/Makefile.inc 2014-07-24 12:16:04.000000000 +0200
++++ sdf3.new/etc/Makefile.inc 2018-12-17 13:53:39.994552004 +0100
+@@ -71,10 +71,9 @@
+ RANLIB = ranlib
+ MAKE = make
+
+-CXXFLAGS = -g -fno-tree-fre -O3 -Wall -D_GNU_SOURCE -D_$(TARGET)_ -pipe -fpic
+-LDFLAGS =
+-ARFLAGS = cru
+-MAKEFLAGS = --no-print-directory
++CXXFLAGS += -fno-tree-fre -fpic
++ARFLAGS = cru
++MAKEFLAGS += --no-print-directory
+
+ OBJ = o
+ CPP = cc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c5e91b4f500
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Chris Lahaye <dev@chrislahaye.com>
+pkgname=sdf3
+pkgver=latest
+pkgrel=1
+pkgdesc='Tool for generating, analyzing, transforming, and visualizing random Synchronous DataFlow Graphs (SDFGs)'
+url='http://www.es.ele.tue.nl/sdf3'
+arch=('i386' 'x86_64')
+license=('GPL')
+depends=('boost-libs' 'libxml2')
+makedepends=('chrpath' 'unzip')
+source=('http://www.es.ele.tue.nl/sdf3/download/files/releases/sdf3.zip' 'Makefile.inc.patch')
+md5sums=('77eadba886cf8c02b7c6831bd62cb675' '0607b3b91e382beeb452c0fbfee0e768')
+noextract=('sdf3.zip')
+options=('!makeflags')
+
+prepare() {
+ unzip sdf3.zip
+ patch -p0 -i Makefile.inc.patch
+}
+
+build() {
+ cd sdf3
+ make
+}
+
+package() {
+ cd sdf3/build/release/Linux
+
+ mkdir -p $pkgdir/usr/bin $pkgdir/usr/lib
+ install -Dm755 bin/* $pkgdir/usr/bin
+ install -Dm755 lib/* $pkgdir/usr/lib
+
+ find $pkgdir/usr/bin -type f -exec chrpath -d {} \+
+}