summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xPKGBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 840aae8198ba..3f39f19ea92e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,9 +23,7 @@ validpgpkeys=('SKIP') # Sam Lantinga
pkgver() {
cd SDL
- _tag=$(hg tags -q | sort -r | grep release- | head -n1)
- _commits=$(hg log --template "{node}\n" -r $_tag:tip | wc -l)
- echo "${_tag/release-}.r$_commits.$(hg identify -i)"
+ echo $(hg parents --template '{word(-1,latesttag,":")}').$(hg identify -n)
}
prepare() {