summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD43
-rw-r--r--sdl2-ime-support.install10
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87079f5d0979
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by mksrcinfo v8
+# Sun Aug 21 09:11:26 UTC 2016
+pkgbase = sdl2-ime-support
+ pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) [with IME support]
+ pkgver = 2.0.4
+ pkgrel = 1
+ url = http://www.libsdl.org
+ install = sdl2-ime-support.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = alsa-lib
+ makedepends = mesa
+ makedepends = libpulse
+ makedepends = libxrandr
+ makedepends = libxinerama
+ makedepends = libxkbcommon
+ makedepends = fcitx
+ makedepends = libibus
+ depends = glibc
+ depends = libxext
+ depends = libxrender
+ depends = libx11
+ depends = libgl
+ depends = libxcursor
+ optdepends = alsa-lib: ALSA audio driver
+ optdepends = libpulse: PulseAudio audio driver
+ optdepends = fcitx: fcitx input support
+ optdepends = ibus: IBus input support
+ provides = sdl2=2.0.4
+ conflicts = sdl2
+ source = git+https://github.com/timxx/SDL-fcitx#branch=release-2.0.4
+ md5sums = SKIP
+
+pkgname = sdl2-ime-support
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd4a2a93dbc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: GhettoGirl <github.com/GhettoGirl>
+
+pkgname=sdl2-ime-support
+pkgver=2.0.4
+pkgrel=1
+pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) [with IME support]"
+arch=('i686' 'x86_64')
+url="http://www.libsdl.org"
+license=('MIT')
+depends=('glibc' 'libxext' 'libxrender' 'libx11' 'libgl' 'libxcursor')
+provides=('sdl2=2.0.4')
+conflicts=('sdl2')
+install="$pkgname.install"
+makedepends=('alsa-lib' 'mesa' 'libpulse' 'libxrandr' 'libxinerama' 'libxkbcommon'
+ 'fcitx' 'libibus')
+optdepends=('alsa-lib: ALSA audio driver'
+ 'libpulse: PulseAudio audio driver'
+ 'fcitx: fcitx input support'
+ 'ibus: IBus input support')
+source=("git+https://github.com/timxx/SDL-fcitx#branch=release-$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd SDL-fcitx
+ ./autogen.sh
+ mkdir -p build && cd build
+
+ ../configure --prefix=/usr \
+ --enable-sdl-dlopen \
+ --disable-arts --disable-esd --disable-nas \
+ --enable-alsa --enable-pulseaudio-shared \
+ --disable-video-wayland \
+ --enable-ibus \
+ --enable-fcitx \
+ --disable-rpath
+ make -j$(nproc)
+}
+
+package() {
+ cd SDL-fcitx/build
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/sdl2-ime-support.install b/sdl2-ime-support.install
new file mode 100644
index 000000000000..c647a266afbf
--- /dev/null
+++ b/sdl2-ime-support.install
@@ -0,0 +1,10 @@
+
+post_install() {
+ echo "=== SDL2 with IME support ==="
+ echo "To enable advanced input methods in SDL2 applications, set the"
+ echo "environment variable SDL_IM_MODULE either to 'fcitx' or 'ibus'"
+}
+
+post_upgrade() {
+ post_install
+}