summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09e49bb1d17d..c9e03d6a2185 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sdl2-nox
pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support
- pkgver = 2.0.14
- pkgrel = 0
+ pkgver = 2.24.0
+ pkgrel = 1
url = http://www.libsdl.org
arch = x86_64
arch = arm
@@ -16,8 +16,7 @@ pkgbase = sdl2-nox
optdepends = libpulse: PulseAudio audio driver
provides = sdl2
conflicts = sdl2
- source = https://www.libsdl.org/release/SDL2-2.0.14.tar.gz
- sha512sums = ebc482585bd565bf3003fbcedd91058b2183e333b9ea566d2f386da0298ff970645d9d25c1aa4459c7c96e9ea839fd1c5f2da0242a56892865b2e456cdd027ee
+ source = https://www.libsdl.org/release/SDL2-2.24.0.tar.gz
+ sha512sums = 5735bfc7b22f1780f80cc89f62a14ca809fe1280298d172f92dde74400db1f5378f8d3eae8834e886d3ca4f5ae6f1074d66c5c956613cf9e0cce961738514212
pkgname = sdl2-nox
-
diff --git a/PKGBUILD b/PKGBUILD
index ac8ffc127ef4..30a9d98db2df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# In order to use this on the Raspberry PI, you must either use the kms or fkms driver.
pkgname=sdl2-nox
-pkgver=2.0.14
-pkgrel=0
+pkgver=2.24.0
+pkgrel=1
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support"
arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="http://www.libsdl.org"
@@ -16,22 +16,20 @@ conflicts=('sdl2')
optdepends=('alsa-lib: ALSA audio driver'
'libpulse: PulseAudio audio driver')
source=("https://www.libsdl.org/release/SDL2-${pkgver}.tar.gz")
-sha512sums=('ebc482585bd565bf3003fbcedd91058b2183e333b9ea566d2f386da0298ff970645d9d25c1aa4459c7c96e9ea839fd1c5f2da0242a56892865b2e456cdd027ee')
+sha512sums=('5735bfc7b22f1780f80cc89f62a14ca809fe1280298d172f92dde74400db1f5378f8d3eae8834e886d3ca4f5ae6f1074d66c5c956613cf9e0cce961738514212')
build() {
- cd "SDL2-$pkgver"
- ./configure --prefix=/usr \
- --enable-sdl-dlopen --enable-video-kmsdrm \
+ mkdir -p build
+ cd build
+ ../SDL2-$pkgver/configure --prefix=/usr \
--disable-arts --disable-esd --disable-nas \
- --enable-alsa --enable-pulseaudio-shared \
- --disable-video-x11 --disable-video-opengl
+ --enable-pulseaudio-shared --enable-video-kmsdrm \
+ --without-x --disable-video-wayland --disable-video-rpi
make
}
-
package() {
- cd "SDL2-$pkgver"
- make DESTDIR="$pkgdir" install
- install -Dm644 ../SDL2-$pkgver/COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd build
+ make install DESTDIR="$pkgdir"
+ install -Dm644 ../SDL2-$pkgver/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-