summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..918065d2f056
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sdl2-nox
+ pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support
+ pkgver = 2.0.7
+ pkgrel = 1
+ url = http://www.libsdl.org
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = alsa-lib
+ depends = bash
+ optdepends = alsa-lib: ALSA audio driver
+ optdepends = libpulse: PulseAudio audio driver
+ provides = sdl2
+ conflicts = sdl2
+ source = https://www.libsdl.org/release/SDL2-2.0.7.tar.gz
+ sha512sums = eed5477843086a0e66552eb197a5c4929134522bc366d873732361ea0df5fb841ef7e2b1913e21d1bae69e6fd3152ee630492e615c58cbe903e7d6e47b587410
+
+pkgname = sdl2-nox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94bd3990bee3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Christer Solskogen <christer.solskogen@gmail.com>
+pkgname=sdl2-nox
+pkgver=2.0.7
+pkgrel=1
+pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support"
+arch=('x86_64' 'arm' 'armv6h' 'armv7h')
+url="http://www.libsdl.org"
+license=('MIT')
+depends=('bash')
+makedepends=('alsa-lib')
+provides=('sdl2')
+conflicts=('sdl2')
+
+optdepends=('alsa-lib: ALSA audio driver'
+ 'libpulse: PulseAudio audio driver')
+source=("https://www.libsdl.org/release/SDL2-${pkgver}.tar.gz")
+sha512sums=('eed5477843086a0e66552eb197a5c4929134522bc366d873732361ea0df5fb841ef7e2b1913e21d1bae69e6fd3152ee630492e615c58cbe903e7d6e47b587410')
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+ ../SDL2-$pkgver/configure --prefix=/usr \
+ --enable-sdl-dlopen \
+ --disable-arts --disable-esd --disable-nas \
+ --enable-alsa --enable-pulseaudio-shared \
+ --disable-video-mir --disable-video-wayland \
+ --disable-video-x11 --disable-video-opengl
+
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../SDL2-$pkgver/COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+