summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--fix_build.diff13
3 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae55710f02ef..ad16e02ca940 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = seafile
pkgdesc = An online file storage and collaboration tool
- pkgver = 9.0.5
+ pkgver = 9.0.6
pkgrel = 1
url = https://github.com/haiwen/seafile
arch = i686
@@ -19,9 +19,11 @@ pkgbase = seafile
depends = sqlite
provides = seafile-client-cli
conflicts = seafile-server
- source = seafile-9.0.5.tar.gz::https://github.com/haiwen/seafile/archive/v9.0.5.tar.gz
+ source = seafile-9.0.6.tar.gz::https://github.com/haiwen/seafile/archive/v9.0.6.tar.gz
+ source = fix_build.diff
source = seaf-cli@.service
- sha256sums = 9a1743784fda646cd7713b5d7eb8a685372ca46c61db1f484037bf5a1f01b7ce
+ sha256sums = e0a1260ac995ad21a183cf73e647fe18e4fc06045f601ab5abcc4b62d07c2280
+ sha256sums = 291a7e67a54dcd1d7b60301339feb1dc4048e301f5b4054e3e1084dfcff3ac0f
sha256sums = c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba
pkgname = seafile
diff --git a/PKGBUILD b/PKGBUILD
index fcfd6f4b7231..1408cc077d90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=seafile
-pkgver=9.0.5
+pkgver=9.0.6
pkgrel=1
pkgdesc='An online file storage and collaboration tool'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
@@ -25,16 +25,19 @@ makedepends=(
conflicts=('seafile-server')
source=(
"seafile-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ 'fix_build.diff'
"seaf-cli@.service"
)
sha256sums=(
- '9a1743784fda646cd7713b5d7eb8a685372ca46c61db1f484037bf5a1f01b7ce'
+ 'e0a1260ac995ad21a183cf73e647fe18e4fc06045f601ab5abcc4b62d07c2280'
+ '291a7e67a54dcd1d7b60301339feb1dc4048e301f5b4054e3e1084dfcff3ac0f'
'c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba'
)
provides=('seafile-client-cli')
prepare() {
cd "$srcdir/seafile-$pkgver"
+ patch -p1 -i "$srcdir/fix_build.diff"
sed -i 's|(DESTDIR)@prefix@|@prefix@|' './lib/libseafile.pc.in'
}
diff --git a/fix_build.diff b/fix_build.diff
new file mode 100644
index 000000000000..f161d35f5c58
--- /dev/null
+++ b/fix_build.diff
@@ -0,0 +1,13 @@
+diff --git a/daemon/repo-mgr.c b/daemon/repo-mgr.c
+index 8be4f04b..f970abf0 100644
+--- a/daemon/repo-mgr.c
++++ b/daemon/repo-mgr.c
+@@ -4885,7 +4885,7 @@ out:
+ // Since file creation is asynchronous, the file may not have been created locally at the time of checking for case conflicts,
+ // so an additional check for the name of the file being created is required.
+ static gboolean
+-is_adding_files_case_conflict (GList **adding_files, const char *name, const char **conflict_path)
++is_adding_files_case_conflict (GList **adding_files, const char *name, char **conflict_path)
+ {
+ GList *ptr;
+ SeafStat st;