summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD53
-rw-r--r--libseafile.in.patch8
-rw-r--r--seaf-cli@.service14
5 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bacf888adbae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = seafile-git
+ pkgdesc = Seafile sync client daemon, latest version.
+ pkgver = 7.0.1
+ pkgrel = 1
+ url = https://github.com/haiwen/seafile
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL2
+ makedepends = vala
+ makedepends = intltool
+ depends = libsearpc>=3.1.0
+ depends = libevent
+ depends = fuse
+ depends = python2
+ depends = sqlite
+ provides = seafile-client-cli-git
+ conflicts = seafile-server
+ conflicts = seafile
+ source = seafile-git-7.0.1.tar.gz::https://github.com/haiwen/seafile/archive/v7.0.1.tar.gz
+ source = libseafile.in.patch
+ source = seaf-cli@.service
+ sha256sums = c79a186e3a512454cb65d863bd45ecc8ae2c66a0dd2010533f3fed7862fa92f8
+ sha256sums = a2d7f7cf0c59aba97650af62b3cefd0ceb71a1007c34d9369a88e5769c7f6076
+ sha256sums = c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba
+
+pkgname = seafile-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..abc06d159603
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.gz
+*.xz
+*.zip
+/pkg
+/src
+*.log*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3977c8d50be1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: h44z <christoph [at] from [doT] tirol>
+# Contributor: eolianoe <eolianoe [at] gmail [DoT] com>
+# Contributor: Edvinas Valatka <edacval@gmail.com>
+# Contributor: Aaron Lindsay <aaron@aclindsay.com>
+
+pkgname=seafile-git
+pkgver=7.0.1
+pkgrel=1
+pkgdesc="Seafile sync client daemon, latest version."
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/haiwen/seafile"
+license=('GPL2')
+depends=("libsearpc" "libevent"
+ "fuse" "python2" "sqlite")
+makedepends=("vala" "intltool")
+conflicts=("seafile-server" "seafile")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "libseafile.in.patch"
+ "seaf-cli@.service")
+sha256sums=('c79a186e3a512454cb65d863bd45ecc8ae2c66a0dd2010533f3fed7862fa92f8'
+ 'a2d7f7cf0c59aba97650af62b3cefd0ceb71a1007c34d9369a88e5769c7f6076'
+ 'c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba')
+provides=('seafile-client-cli-git')
+
+prepare () {
+ cd "${srcdir}/seafile-${pkgver}"
+
+ patch -p1 -i "${srcdir}/libseafile.in.patch"
+
+ # Fix all script's python 2 requirement
+ grep -s -l -r '#!/usr/bin/env python' "${srcdir}/seafile-${pkgver}" \
+ | xargs sed -i -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|g'
+}
+
+build() {
+ cd "$srcdir/seafile-${pkgver}"
+
+ ./autogen.sh
+
+ ./configure \
+ --enable-console \
+ --prefix=/usr \
+ PYTHON=/usr/bin/python2
+
+ make
+}
+
+package() {
+ cd "${srcdir}/seafile-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}"/seaf-cli@.service "${pkgdir}"/usr/lib/systemd/system/seaf-cli@.service
+}
diff --git a/libseafile.in.patch b/libseafile.in.patch
new file mode 100644
index 000000000000..558abd6f03e4
--- /dev/null
+++ b/libseafile.in.patch
@@ -0,0 +1,8 @@
+--- seafile-4.3.1/lib/libseafile.pc.in 2015-08-11 05:40:35.000000000 +0300
++++ seafile-4.3.1/lib/libseafile.pc.in.good 2015-08-18 09:45:24.761932845 +0300
+@@ -1,4 +1,4 @@
+-prefix=(DESTDIR)@prefix@
++prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@
diff --git a/seaf-cli@.service b/seaf-cli@.service
new file mode 100644
index 000000000000..66fc1b633241
--- /dev/null
+++ b/seaf-cli@.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Seafile command line client
+Requires=network-online.target
+After=network-online.target
+
+[Service]
+User=%I
+Type=oneshot
+ExecStart=/usr/bin/seaf-cli start
+ExecStop=/usr/bin/seaf-cli stop
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target