summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12d955232808..b8c12c27507d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = selinux-python2
pkgdesc = SELinux python 2.X tools and libraries
- pkgver = 3.0
+ pkgver = 3.4
pkgrel = 1
url = https://github.com/SELinuxProject/selinux/wiki
arch = i686
@@ -12,11 +12,10 @@ pkgbase = selinux-python2
depends = python2-ipy
depends = libsemanage>=2.8
depends = setools>=4.0.0
- provides = sepolgen=3.0-1
+ provides = sepolgen=3.4-1
conflicts = sepolgen<2.7
conflicts = policycoreutils<2.7
- source = https://github.com/SELinuxProject/selinux/releases/download/20191204/selinux-python-3.0.tar.gz
- sha256sums = 43c08fa881ccc64251d396b1ac6c56b354bf98421b4ec937d54a8db190135494
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.4/selinux-python-3.4.tar.gz
+ sha256sums = 1731065a58293b8a598c0f8b182fdd1a278959b1288747fcb17af392496bac32
pkgname = selinux-python2
-
diff --git a/PKGBUILD b/PKGBUILD
index c384d1778641..6b8ff3b5318a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,29 @@
# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
# If you want to help keep it up to date, please open a Pull Request there.
-pkgname=selinux-python2
-pkgver=3.0
+_pkgname=selinux-python
+pkgname="${_pkgname}2"
+pkgver=3.4
pkgrel=1
pkgdesc="SELinux python 2.X tools and libraries"
groups=('selinux')
arch=('i686' 'x86_64')
-url='https://github.com/SELinuxProject/selinux/wiki'
+_url="https://github.com/SELinuxProject/selinux"
+url="${_url}/wiki"
license=('GPL2')
depends=('python2' 'python2-audit' 'python2-ipy' 'libsemanage>=2.8' 'setools>=4.0.0')
conflicts=('sepolgen<2.7' 'policycoreutils<2.7')
provides=("sepolgen=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/selinux-python-${pkgver}.tar.gz")
-sha256sums=('43c08fa881ccc64251d396b1ac6c56b354bf98421b4ec937d54a8db190135494')
+source=("${_url}/releases/download/${pkgver}/selinux-python-${pkgver}.tar.gz")
+sha256sums=("1731065a58293b8a598c0f8b182fdd1a278959b1288747fcb17af392496bac32")
build() {
- cd "selinux-python-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
make PYTHON=/usr/bin/python2
}
package() {
- cd "selinux-python-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
make PYTHON=/usr/bin/python2 DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
/usr/bin/python2 -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'import site; print(site.getsitepackages()[0])')"
/usr/bin/python2 -O -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'import site; print(site.getsitepackages()[0])')"