summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Fix_system_search_DB.patch76
-rw-r--r--PKGBUILD18
3 files changed, 8 insertions, 96 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec0d496cf29d..0d5e30b3bdf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = seriousrunner
pkgdesc = Serious Runner program that loads and runs content created by users.
- pkgver = 1.1.1
- pkgrel = 2
+ pkgver = 1.1.2
+ pkgrel = 1
url = https://github.com/tx00100xt/Serious-Runner
arch = x86_64
license = GPL2
@@ -18,8 +18,6 @@ pkgbase = seriousrunner
depends = libarchive
depends = xz
depends = bzip2
- source = https://github.com/tx00100xt/Serious-Runner/archive/refs/tags/v1.1.tar.gz
- source = 0001-Fix_system_search_DB.patch
- sha256sums = 530b421aa4fe1fe6fdf0e2ee9ac0f2b00861b28a9f277098b10f20a38fd337e0
- sha256sums = 148a2ba597789d646678956bf11f3699adc11dfb03aa97f3f11ed429a74e5c25
+ source = https://github.com/tx00100xt/Serious-Runner/archive/refs/tags/v1.1.2.tar.gz
+ sha256sums = 725decc771bed6199333959dec2fccc4766844d8c692ae7dbbf538183146cbfd
pkgname = seriousrunner
diff --git a/0001-Fix_system_search_DB.patch b/0001-Fix_system_search_DB.patch
deleted file mode 100644
index b03e1f2c3fa8..000000000000
--- a/0001-Fix_system_search_DB.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-diff -aurN a/MainWindow.cpp b/MainWindow.cpp
---- a/MainWindow.cpp 2023-09-30 23:04:24.000000000 +0300
-+++ b/MainWindow.cpp 2023-10-02 18:42:54.817319836 +0300
-@@ -137,9 +137,10 @@
- // Set pathd
- #ifdef PLATFORM_UNIX
- strEngineDirPath = strHomeDirPath + strEngineDirPathSuffix;
-- //strExecDirPath = QCoreApplication::applicationFilePath();
--#endif
-+ strExecDirPath = QCoreApplication::applicationFilePath();
-+#else
- strExecDirPath = QDir::currentPath();
-+#endif
- strRunnerDirPath = strHomeDirPath + strRunnerDirPathSuffix;
- strGameDirFEpath = strRunnerDirPath + "/SamTFE";
- strGameDirSEpath = strRunnerDirPath + "/SamTSE";
-@@ -282,7 +283,7 @@
- }
-
- // Test DB update need?
--bool MainWindow::TestDBupdateNeed()
-+int MainWindow::TestDBupdateNeed()
- {
- int iLocalDBsize = 0;
- QFile scanFile(strRunnerDBPath);
-@@ -290,14 +291,16 @@
- iLocalDBsize = scanFile.size();
- scanFile.close();
- }
-- if(iLocalDBsize == iRemoteSizeDB){
-- return true;
-- }
-- return false;
-+ return iLocalDBsize;
- }
-
- // Search and install DB
- bool MainWindow::SearchDB(){
-+
-+ if (QFile(strRunnerDBPath).exists() && !TestDBupdateNeed()){
-+ QFile file(strRunnerDBPath);
-+ file.remove();
-+ }
- if (!QFile(strRunnerDBPath).exists()){
- if (!QDir(strRunnerDirPath).exists()){
- QDir().mkdir(strRunnerDirPath);
-@@ -782,7 +785,8 @@
-
- void MainWindow::on_pushButton_update_db_clicked()
- {
-- if(TestDBupdateNeed()) {
-+ int iLocalDBsize = TestDBupdateNeed();
-+ if((iLocalDBsize == iRemoteSizeDB) && (iLocalDBsize !=0 )) {
- MsgBox(INFO, "The latest version of the database is installed. No update required!");
- return;
- }
-@@ -1259,7 +1263,6 @@
- m_downloader.GetLevel(strGameDirPath, strDownloadLink);
- }
- }
--
- void MainWindow::on_pushButton_fe_bestmaps_download_clicked()
- {
- if(m_downloader.locked_action) {return;}
-diff -aurN a/MainWindow.h b/MainWindow.h
---- a/MainWindow.h 2023-09-30 23:04:24.000000000 +0300
-+++ b/MainWindow.h 2023-10-02 18:16:07.161147610 +0300
-@@ -184,7 +184,7 @@
- void ReScanLocalDB();
- void HideProgressBars();
- void HideLabelsText();
-- bool TestDBupdateNeed();
-+ int TestDBupdateNeed();
- void MakeDifficultyScript(int iDifficulty, QString strPath);
- void StartLevel(QString strSqlTable, int iXPLUS, int iDifficulty);
- void StartMod(QString strSqlTable, int iDifficulty);
diff --git a/PKGBUILD b/PKGBUILD
index 181cf000a26e..aa11bef68be9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,17 @@
pkgname=seriousrunner
pkginstdir=seriousrunner
-pkgver=1.1.1
+pkgver=1.1.2
_srcname="Serious-Runner-$pkgver"
-pkgrel=2
+pkgrel=1
pkgdesc="Serious Runner program that loads and runs content created by users."
arch=('x86_64')
url="https://github.com/tx00100xt/Serious-Runner"
license=('GPL2')
makedepends=('cmake' 'make' 'sed' 'qt5-base' 'libarchive' 'xz' 'bzip2')
-source=("https://github.com/tx00100xt/Serious-Runner/archive/refs/tags/v$pkgver.tar.gz"
- "0001-Fix_system_search_DB.patch")
-sha256sums=("530b421aa4fe1fe6fdf0e2ee9ac0f2b00861b28a9f277098b10f20a38fd337e0"
- "148a2ba597789d646678956bf11f3699adc11dfb03aa97f3f11ed429a74e5c25")
-
-prepare(){
- # Prepare patch
- cat 0001-Fix_system_search_DB.patch > "$srcdir/$_srcname/0001-Fix_system_search_DB.patch"
- cd "$srcdir/$_srcname"
- # apply patch
- patch -p1 < 0001-Fix_system_search_DB.patch || return 1
-}
+source=("https://github.com/tx00100xt/Serious-Runner/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=("725decc771bed6199333959dec2fccc4766844d8c692ae7dbbf538183146cbfd")
build() {
mkdir "$_srcname"/build && cd "$_srcname"/build