summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f089a90697f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = servicer-bin
+ pkgdesc = Simplify Service Management on systemd
+ pkgver = 0.1.13
+ pkgrel = 1
+ url = https://github.com/servicer-labs/servicer
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ depends = glibc
+ depends = gcc-libs
+ provides = servicer
+ conflicts = servicer
+ source_x86_64 = servicer-bin-0.1.13-1-servicer::https://github.com/servicer-labs/servicer/releases/download/v0.1.13/servicer-x86_64-unknown-linux-gnu
+ source_x86_64 = servicer-bin-0.1.13-1-LICENSE::https://raw.githubusercontent.com/servicer-labs/servicer/master/LICENSE
+ sha256sums_x86_64 = 4a3fb1d9c04e7bb705c7ce68a89dd625647d5da6937d4ae450321b5acaa62946
+ sha256sums_x86_64 = 2ef4d276242ac95eb4005255e73fce401e38ed70354b15aa53b516195db47151
+ source_aarch64 = servicer-bin-0.1.13-1-servicer::https://github.com/servicer-labs/servicer/releases/download/v0.1.13/servicer-x86_64-unknown-linux-gnu
+ source_aarch64 = servicer-bin-0.1.13-1-LICENSE::https://raw.githubusercontent.com/servicer-labs/servicer/master/LICENSE
+ sha256sums_aarch64 = bdb626724589d71308a73b09dd07357710ff1e9a12659ec3b02f31617cdb54e0
+ sha256sums_aarch64 = 2ef4d276242ac95eb4005255e73fce401e38ed70354b15aa53b516195db47151
+
+pkgname = servicer-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cc67b0b4d0bf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..267f524b5624
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: tippfehlr <tippfehlr at tippfehlr dot eu>
+
+pkgname=servicer-bin
+pkgver=0.1.13
+pkgrel=1
+pkgdesc="Simplify service management on systemd"
+url="https://github.com/servicer-labs/servicer"
+license=("MIT")
+arch=("x86_64" "aarch64")
+provides=("servicer")
+conflicts=("servicer")
+depends=(glibc gcc-libs)
+_prefix=$pkgname-$pkgver-$pkgrel
+source_x86_64=(
+ "$_prefix-servicer::$url/releases/download/v$pkgver/servicer-$CARCH-unknown-linux-gnu"
+ "$_prefix-LICENSE::https://raw.githubusercontent.com/servicer-labs/servicer/master/LICENSE"
+)
+source_aarch64=(
+ "$_prefix-servicer::$url/releases/download/v$pkgver/servicer-$CARCH-unknown-linux-gnu"
+ "$_prefix-LICENSE::https://raw.githubusercontent.com/servicer-labs/servicer/master/LICENSE"
+)
+sha256sums_x86_64=(
+ "4a3fb1d9c04e7bb705c7ce68a89dd625647d5da6937d4ae450321b5acaa62946"
+ "2ef4d276242ac95eb4005255e73fce401e38ed70354b15aa53b516195db47151"
+)
+sha256sums_aarch64=(
+ "bdb626724589d71308a73b09dd07357710ff1e9a12659ec3b02f31617cdb54e0"
+ "2ef4d276242ac95eb4005255e73fce401e38ed70354b15aa53b516195db47151"
+)
+
+package() {
+ install -Dm755 $_prefix-servicer -t "$pkgdir/usr/bin"
+ install -Dm644 $_prefix-LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}