summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02e190af4260
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = shapely
+ pkgdesc = Shapely is a BSD-licensed Python package for manipulation and analysis of planar geometric objects.
+ pkgver = 1.6
+ pkgrel = 1
+ url = https://github.com/Toblerity/Shapely
+ arch = x86_64
+ groups = ipkiss
+ license = BSD
+ depends = geos
+ source = git+https://github.com/Toblerity/Shapely.git
+ md5sums = SKIP
+
+pkgname = shapely
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62c1ffef6db9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jean-Luc Tambasco <an.obscurity@gmail.com>
+
+pkgname=shapely
+pkgver=1.6
+pkgrel=1
+pkgdesc="Shapely is a BSD-licensed Python package for manipulation and analysis of planar geometric objects."
+arch=('x86_64')
+url="https://github.com/Toblerity/Shapely"
+license=('BSD')
+groups=('ipkiss')
+depends=('geos')
+source=('git+https://github.com/Toblerity/Shapely.git')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/${pkgname^}"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname^}"
+ python2 setup.py install --user
+}