summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--[-rwxr-xr-x].SRCINFO28
-rw-r--r--[-rwxr-xr-x].gitignore12
-rw-r--r--[-rwxr-xr-x]PKGBUILD81
3 files changed, 61 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7299e0037204..0ceb14b521f3 100755..100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = shellcheck-git
- pkgdesc = A shell script static analysis tool: Git Release
- pkgver = 0.4.3.r75.g6b62b5b
+ pkgdesc = Shell script analysis tool (latest git commit)
+ pkgver = 0.4.6.git20171108
pkgrel = 1
- url = http://www.shellcheck.net/
+ url = http://www.shellcheck.net
arch = i686
arch = x86_64
- license = AGPL3
- makedepends = git
- makedepends = ghc
- makedepends = haskell-json
- makedepends = haskell-mtl
- makedepends = haskell-parsec
- makedepends = haskell-quickcheck
- makedepends = haskell-regex-tdfa
- depends = gmp
- provides = shellcheck
+ license = GPL3
+ depends = ghc
+ depends = haskell-json
+ depends = haskell-mtl
+ depends = haskell-parsec
+ depends = haskell-quickcheck
+ depends = haskell-regex-tdfa
+ provides = shellcheck=0.4.6.git20171108
conflicts = shellcheck
- source = shellcheck-git::git+https://github.com/koalaman/shellcheck.git
- md5sums = SKIP
+ source = shellcheck-51e6bf809fc7157b60bdb2c499d6b769b48d0759.zip::https://github.com/koalaman/shellcheck/archive/51e6bf809fc7157b60bdb2c499d6b769b48d0759.tar.gz
+ sha512sums = 67a70c91ae7d7f01e522438f54f26db41567a1a6a59fad10739b53960a3469af768e38dd9e610ee188f4422fecf493bf11bf672c95760250c62f78a779eaf2de
pkgname = shellcheck-git
diff --git a/.gitignore b/.gitignore
index 181b3460e424..a8f8b6ce0752 100755..100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,10 +1,2 @@
-*
-!PKGBUILD
-!.SRCINFO
-!*.patch
-!*.desktop
-!*.install
-!*.service
-!*.sh
-!*.conf
-!.gitignore
+*.pkg.tar.?z
+*.src.tar.?z
diff --git a/PKGBUILD b/PKGBUILD
index e20e10cf5c4b..aef5b38e7e96 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,55 @@
-# Maintainer: Nissar Chababy <funilrys at outlook dot com>
-# Ex-Maintainer: Justin Dray <justin@dray.be>
-# Contributor: Josh McGee <josh.s.mcgee@gmail.com>
-# Contributor: Earnestly <zibeon@gmail.com>
+# Maintainer: Luke Shumaker <lukeshu@lukeshu.com>
+# Maintainer (Arch:shellcheck): Felix Yan <felixonmars@archlinux.org>
+# Contributor (Arch:shellcheck): Arch Haskell Team <arch-haskell@haskell.org>
-pkgname=shellcheck-git
-pkgver=0.4.3.r75.g6b62b5b
+_hkgname=ShellCheck
+_pkgname=shellcheck
+_pkgver=0.4.6
+_gitrev='51e6bf809fc7157b60bdb2c499d6b769b48d0759'
+_gitdate='20171108'
+pkgname=$_pkgname-git
+pkgver="$_pkgver.git$_gitdate"
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
pkgrel=1
-pkgdesc="A shell script static analysis tool: Git Release"
-arch=(i686 x86_64)
-url=http://www.shellcheck.net/
-license=('AGPL3')
-depends=('gmp')
-makedepends=('git'
- 'ghc'
- 'haskell-json'
- 'haskell-mtl'
- 'haskell-parsec'
- 'haskell-quickcheck'
- 'haskell-regex-tdfa')
-provides=(shellcheck)
-conflicts=(shellcheck)
-source=("$pkgname::git+https://github.com/koalaman/shellcheck.git")
-md5sums=('SKIP')
+pkgdesc="Shell script analysis tool"
+pkgdesc+=" (latest git commit)"
+url="http://www.shellcheck.net"
+license=("GPL3") # NB: community/shellcheck is erroneously GPL2
+arch=('i686' 'x86_64')
+depends=('ghc' "haskell-json" "haskell-mtl" "haskell-parsec" "haskell-quickcheck"
+ "haskell-regex-tdfa")
+source=("$_pkgname-$_gitrev.zip::https://github.com/koalaman/$_pkgname/archive/$_gitrev.tar.gz")
+sha512sums=('67a70c91ae7d7f01e522438f54f26db41567a1a6a59fad10739b53960a3469af768e38dd9e610ee188f4422fecf493bf11bf672c95760250c62f78a779eaf2de')
-pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed -r 's/^v//g;s/([^-]*-g)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "$pkgname"
- runhaskell Setup configure --prefix=/usr --docdir="/usr/share/doc/${pkgname}" -O
-}
build() {
- cd "$pkgname"
- runhaskell Setup -v build
+ cd "${srcdir}/${_pkgname}-${_gitrev}"
+
+ # NB: community/shellcheck doesn't --disable-library-vanilla; but
+ # it's required to build with current ghc/libraries.
+ runhaskell Setup configure -O \
+ --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${_pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock --hoogle --html
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
package() {
- cd "$pkgname"
- runhaskell Setup copy --destdir="${pkgdir}"
+ cd "${srcdir}/${_pkgname}-${_gitrev}"
+
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${_pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${_pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s "/usr/share/doc/${_pkgname}/html" "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ rm -f "${pkgdir}/usr/share/doc/${_pkgname}/LICENSE"
+
+ # Remove static libs
+ find "$pkgdir"/usr/lib -name "*.a" -delete
}