summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9439f28ad108
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = shellfirm-bin
+ pkgdesc = Intercept any risky patterns (default or defined by you) and prompt you a small challenge for double verification
+ pkgver = 0.2.6
+ pkgrel = 1
+ url = https://github.com/kaplanelad/shellfirm
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = rust
+ source = shellfirm-0.2.6.tar.gz::https://github.com/kaplanelad/shellfirm/archive/refs/tags/v0.2.6.tar.gz
+ sha256sums = 0dd22e933763e01e14e816ae839c54d0b48fd802ddee8ae3fe66043a47b1411b
+
+pkgname = shellfirm-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aaf0bf4e663c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Manish Khadka <manish.khadka@tutanota.com>
+
+pkgname=shellfirm-bin
+pkgorg=shellfirm
+pkgver=0.2.6
+pkgrel=1
+pkgdesc='Intercept any risky patterns (default or defined by you) and prompt you a small challenge for double verification'
+arch=('x86_64')
+url='https://github.com/kaplanelad/shellfirm'
+makedepends=('git' 'rust')
+license=('Apache')
+source=("$pkgorg-$pkgver.tar.gz::https://github.com/kaplanelad/shellfirm/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('0dd22e933763e01e14e816ae839c54d0b48fd802ddee8ae3fe66043a47b1411b')
+
+build() {
+ cd "$srcdir/$pkgorg-$pkgver"
+ cargo build --release
+}
+
+test() {
+ cd "$srcdir/$pkgorg-$pkgver"
+ cargo test --release
+}
+
+package() {
+ cd "$srcdir/$pkgorg-$pkgver"
+ install -Dm755 target/release/shellfirm $pkgdir/usr/bin/shellfirm
+ install -d -m 755 "${pkgdir}/usr/share/licenses/${pkgorg}"
+ install -D -m 644 ./LICENSE "${pkgdir}/usr/share/licenses/${pkgorg}"/
+
+ cd docs
+ install -d -m 755 "${pkgdir}/usr/share/doc/${pkgorg}"
+ find . -type d -exec install -d {,"$pkgdir"/usr/share/doc/${pkgorg}/}{} \;
+ find . -type f -exec install -D {,"$pkgdir"/usr/share/doc/${pkgorg}/}{} \;
+}