summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bacb1843c4d0..af5627668335 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = shimo-bin
pkgdesc = 石墨文档 Shimo document (An online collaborative office software).
- pkgver = 3.2.0
+ pkgver = 3.3.1
pkgrel = 1
url = https://shimo.im/
arch = x86_64
+ arch = aarch64
license = custom
depends = nss
depends = alsa-lib
@@ -11,7 +12,9 @@ pkgbase = shimo-bin
depends = libnet
depends = gtk3
depends = libxkbcommon-x11
- source = https://oas.shimonote.com/panther/shimo/release/linux/x64/shimo_v3.2.0-release.32738d1.shimo_linux-amd64.deb
- sha512sums = 74b8c4bef2c385874075a89a08aa5286adceb32d4ea614365849138d0454445a086523fcbf3a4645dfdcb1d7b4e91c838335d49b0f7b0a494bd5ca0f7f521403
+ source_x86_64 = https://oas.shimonote.com/panther/shimo/release/linux/x64/shimo_v3.3.1-release.ea23524.shimo_linux-amd64.deb
+ sha512sums_x86_64 = 8ea8a82a17d8128e4ed7421bb42e194421264ff630c9d3f648cb85796f7dfe3b2e83f58873bff704345abcbbad87e610455db352c8b8ef7aa55ddcee5b78af16
+ source_aarch64 = https://oas.shimonote.com/panther/shimo/release/linux/arm64/shimo_v3.3.1-release.ea23524.shimo_linux-arm64.deb
+ sha512sums_aarch64 = 1f042280754be9d9732844ea1180abca93b3a3ac357418a98ef3394b78fc97ac2c5330ae229b3ea650b2c3506a49ee88efc67f493ac6fe440f47516e27952f3a
pkgname = shimo-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2e1aab0f7bc4..430a79398dfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer:Integral<luckys68@126.com>
+# Maintainer: Integral <integral@murena.io>
+
pkgname=shimo-bin
-_pkgname=shimo
-pkgver=3.2.0
+_pkgname=${pkgname%-bin}
+pkgver=3.3.1
pkgrel=1
pkgdesc="石墨文档 Shimo document (An online collaborative office software)."
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://shimo.im/"
license=('custom')
depends=('nss' 'alsa-lib' 'java-runtime' 'libnet' 'gtk3' 'libxkbcommon-x11')
-source=(
- "https://oas.shimonote.com/panther/shimo/release/linux/x64/${_pkgname}_v${pkgver}-release.32738d1.shimo_linux-amd64.deb"
-)
-sha512sums=('74b8c4bef2c385874075a89a08aa5286adceb32d4ea614365849138d0454445a086523fcbf3a4645dfdcb1d7b4e91c838335d49b0f7b0a494bd5ca0f7f521403')
+source_x86_64=("https://oas.shimonote.com/panther/${_pkgname}/release/linux/x64/${_pkgname}_v${pkgver}-release.ea23524.shimo_linux-amd64.deb")
+source_aarch64=("https://oas.shimonote.com/panther/${_pkgname}/release/linux/arm64/${_pkgname}_v${pkgver}-release.ea23524.shimo_linux-arm64.deb")
+sha512sums_x86_64=('8ea8a82a17d8128e4ed7421bb42e194421264ff630c9d3f648cb85796f7dfe3b2e83f58873bff704345abcbbad87e610455db352c8b8ef7aa55ddcee5b78af16')
+sha512sums_aarch64=('1f042280754be9d9732844ea1180abca93b3a3ac357418a98ef3394b78fc97ac2c5330ae229b3ea650b2c3506a49ee88efc67f493ac6fe440f47516e27952f3a')
package() {
echo " -> Extracting the data.tar.gz..."
@@ -19,9 +20,11 @@ package() {
chmod -R 755 "${pkgdir}/"
echo " -> Installing..."
+
# Launcher
mkdir -p "${pkgdir}/usr/bin/"
ln -s "/opt/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
# License
install -Dm644 "${pkgdir}/opt/shimo/LICENSE.electron.txt" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
install -Dm644 "${pkgdir}/opt/shimo/LICENSES.chromium.html" -t "${pkgdir}/usr/share/licenses/${pkgname}/"