summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
-rw-r--r--sickchill-git.install4
-rw-r--r--sickchill.tmpfiles2
4 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb054c8c5988..db5df343f4e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,7 +15,9 @@ pkgbase = sickchill-git
options = !strip
source = sickchill.service
source = sickchill.sysusers
+ source = sickchill.tmpfiles
sha256sums = ca6a73f7c2019ddda2b338eb63be560bf1a5d6ae5ceab969dc032c05b6d2d7b5
sha256sums = 1467f3613f5f25e678e373465dc09a28230f7cdf07af23875a0896a509c3b850
+ sha256sums = 2069f15e18fc7dd0f0f25b623f2067fc9028b1ca4122021a62364aa39914f88f
pkgname = sickchill-git
diff --git a/PKGBUILD b/PKGBUILD
index a2e98fa2833c..11da10f86f2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,14 +14,16 @@ license=('GPL3')
makedepends=('jq' 'python-virtualenv')
optdepends=('libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename'
'unrar: for RAR files')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
options=('!strip')
install=$pkgname.install
source=('sickchill.service'
- 'sickchill.sysusers')
+ 'sickchill.sysusers'
+ 'sickchill.tmpfiles')
sha256sums=('ca6a73f7c2019ddda2b338eb63be560bf1a5d6ae5ceab969dc032c05b6d2d7b5'
- '1467f3613f5f25e678e373465dc09a28230f7cdf07af23875a0896a509c3b850')
+ '1467f3613f5f25e678e373465dc09a28230f7cdf07af23875a0896a509c3b850'
+ '2069f15e18fc7dd0f0f25b623f2067fc9028b1ca4122021a62364aa39914f88f')
pkgver() {
local version
@@ -44,9 +46,9 @@ build() {
package() {
install -Dm644 sickchill.service -t "$pkgdir/usr/lib/systemd/system"
install -Dm644 sickchill.sysusers "$pkgdir/usr/lib/sysusers.d/sickchill.conf"
+ install -Dm644 sickchill.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/sickchill.conf"
- install -dm755 "$pkgdir/opt/sickchill/data"
-
+ install -dm755 "$pkgdir/opt/sickchill"
cp -a build "$pkgdir/opt/sickchill/app"
}
diff --git a/sickchill-git.install b/sickchill-git.install
index b2aac1beb1ba..ec77a162e764 100644
--- a/sickchill-git.install
+++ b/sickchill-git.install
@@ -1,15 +1,11 @@
post_install() {
post_upgrade
-
echo "==> Start and enable sickchill.service. Then visit http://localhost:8081/"
}
post_upgrade() {
systemd-sysusers sickchill.conf
- systemd-tmpfiles --create sickchill.conf
-
chown -R sickchill:sickchill /opt/sickchill/app
- chown sickchill:sickchill /opt/sickchill/data
}
pre_remove() {
diff --git a/sickchill.tmpfiles b/sickchill.tmpfiles
new file mode 100644
index 000000000000..8c5678142f7d
--- /dev/null
+++ b/sickchill.tmpfiles
@@ -0,0 +1,2 @@
+#d /var/lib/sickchill/data 0750 sickchill sickchill
+d /opt/sickchill/data 0750 sickchill sickchill