summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--sickrage-git.install19
3 files changed, 9 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 691239423674..bd138f3383ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sickrage-git
pkgdesc = A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage, torrents and anime support.
- pkgver = 8.8.4.r85.gb1b4f64e5
+ pkgver = 9.2.101.r0.g986e796a7
pkgrel = 1
url = https://github.com/SiCKRAGETV/SickRage
install = sickrage-git.install
@@ -18,7 +18,7 @@ pkgbase = sickrage-git
provides = sickrage
conflicts = sickrage
options = !strip
- source = sickrage-git::git://github.com/SiCKRAGETV/SickRage.git
+ source = sickrage-git::git+https://git.sickrage.ca/SiCKRAGE/sickrage.git
source = sickrage.service
source = sickrage.sysusers
source = sickrage.tmpfile
diff --git a/PKGBUILD b/PKGBUILD
index d4e6b1d605e4..bec0e4a06561 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=sickrage
pkgname=$_pkgname-git
-pkgver=8.8.4.r85.gb1b4f64e5
+pkgver=9.2.101.r0.g986e796a7
pkgrel=1
pkgdesc="A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage, torrents and anime support."
arch=('any')
@@ -27,7 +27,8 @@ provides=($_pkgname)
conflicts=($_pkgname)
options=('!strip')
install=$pkgname.install
-source=("$pkgname::git://github.com/SiCKRAGETV/SickRage.git"
+#source=("$pkgname::git://github.com/SiCKRAGETV/SickRage.git"
+source=("$pkgname::git+https://git.sickrage.ca/SiCKRAGE/sickrage.git"
'sickrage.service'
'sickrage.sysusers'
'sickrage.tmpfile')
@@ -43,7 +44,7 @@ pkgver() {
build() {
cd $pkgname
- python2 setup.py build
+ python2 setup.py --quiet build
}
#check() {
@@ -62,5 +63,7 @@ package() {
#cd $pkgname
#python2 setup.py install --prefix=/opt/sickrage/app --install-lib=/opt/sickrage/app --root="$pkgdir" --optimize=1
cp -rp $pkgname/* "$pkgdir/opt/sickrage/app/"
+
+ warning "If the upgrade fails with \"error: failed to commit transaction (conflicting files)\", then uninstall first"
}
diff --git a/sickrage-git.install b/sickrage-git.install
index d1e1b2fb8290..107c9fcb3296 100644
--- a/sickrage-git.install
+++ b/sickrage-git.install
@@ -1,25 +1,8 @@
-# Colored makepkg-like functions
-note() {
- printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
-}
-all_off="$(tput sgr0)"
-bold="${all_off}$(tput bold)"
-blue="${bold}$(tput setaf 4)"
-yellow="${bold}$(tput setaf 3)"
-
post_install() {
systemd-sysusers sickrage.conf
systemd-tmpfiles --create sickrage.conf
chown -R sickrage:sickrage /opt/sickrage
- note "Configuration files have moved to /opt/sickrage/data."
- echo " To migrate, run the following commands as root and then reinstall:"
- echo " systemctl stop sickrage.service"
- echo " pacman -Rn sickrage-git"
- echo " cp -a /opt/sickrage{,.bak}"
- echo ' rm -r $(ls -1d /opt/sickrage/* | grep -Ev "/backup.*|/cache.*|/config.ini.*|/Log.*|/.*\.db.*")'
- echo " mkdir -p /opt/sickrage/data"
- echo " mv /opt/sickrage/* /opt/sickrage/data/"
- note "If an upgrade fails with \"error: failed to commit transaction (conflicting files)\", then uninstall first."
+
echo "==> Start and enable sickrage.service. Then visit http://localhost:8081/"
}