summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
-rw-r--r--sickrage-git.install6
3 files changed, 29 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ef5bbada723..3f02d33baa19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v7
+# Mon Nov 2 14:02:43 UTC 2015
pkgbase = sickrage-git
- pkgdesc = A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage and torrents support.
- pkgver = 4.0.54.r0.g3fb81bd
+ pkgdesc = A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage, torrents and anime support.
+ pkgver = 4.1.0.r0.g533d8c1
pkgrel = 1
url = https://github.com/SiCKRAGETV/SickRage
install = sickrage-git.install
@@ -10,9 +12,8 @@ pkgbase = sickrage-git
depends = python2-mako
depends = python2-cheetah
optdepends = python2-notify: desktop notifications
- optdepends = python2-pyopenssl: enable ssl
- optdepends = sabnzbd: NZB downloader
- optdepends = unrar: rar archives
+ optdepends = python2-pyopenssl: enable SSL
+ optdepends = unrar: RAR archives
provides = sickrage
conflicts = sickrage
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 86f40b58e82d..d24ed265c0e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,33 @@
# Maintainer: willemw <willemw12@gmail.com>
# Contibutor: Justin Dray <justin@dray.be>
+
+# In case of upgrade errors:
+# error: failed to commit transaction (conflicting files)
+# sickrage-git: /opt/sickrage/... exists in filesystem
+# Try to remove all or most of the conflicting files:
+# # rm -rf /opt/sickrage/{contrib/,contributing.md,COPYING.txt,gui/,lib/,runscripts/,sickbeard/,SickBeard.py,sickrage/,tests/}
+# Use at your own risk!
+
+
_pkgname=sickrage
pkgname=$_pkgname-git
-pkgver=4.0.54.r0.g3fb81bd
+pkgver=4.1.0.r0.g533d8c1
pkgrel=1
-pkgdesc="A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage and torrents support."
+pkgdesc="A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage, torrents and anime support."
arch=('any')
url="https://github.com/SiCKRAGETV/SickRage"
license=('GPL3')
-depends=('python2-mako' 'python2-cheetah')
makedepends=('git')
+depends=('python2-mako' 'python2-cheetah')
+# 'deluge: supported torrent client'
+# 'qbittorrent: supported torrent client'
+# 'rtorrent: supported torrent client'
+# 'sabnzbd: supported NZB downloader'
+# 'transmission-cli: supported torrent client'
optdepends=('python2-notify: desktop notifications'
- 'python2-pyopenssl: enable ssl'
- 'sabnzbd: NZB downloader'
- 'unrar: rar archives')
+ 'python2-pyopenssl: enable SSL'
+ 'unrar: RAR archives')
provides=($_pkgname)
conflicts=($_pkgname)
options=('!strip')
@@ -31,13 +44,8 @@ pkgver() {
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd $pkgname
- sed -i 's|#![ \t]*/usr/bin/env python[ \t\r]*$|#!/usr/bin/env python2|' autoProcessTV/*.py
-}
-
package() {
- # 'source' install type. Does not include git repository files
+ # The "source" sickrage install type does not include the .git folder (git repository files)
install -dm755 "$pkgdir/opt/sickrage"
cp -rp $pkgname/* "$pkgdir/opt/sickrage"
diff --git a/sickrage-git.install b/sickrage-git.install
index 479e1e715f97..759a81402a73 100644
--- a/sickrage-git.install
+++ b/sickrage-git.install
@@ -1,5 +1,5 @@
post_install() {
- SB_DATA=/opt/sickrage
+ SR_DATA=/opt/sickrage
# Create or repair SickRage user/group.
if grep -q "^sickrage" /etc/group &> /dev/null ; then
@@ -8,9 +8,9 @@ post_install() {
groupadd -r sickrage &> /dev/null
fi
if grep -q "^sickrage:" /etc/passwd 2> /dev/null ; then
- usermod -s /bin/false -c "SickRage daemon user" -d $SB_DATA -g sickrage sickrage &> /dev/null
+ usermod -s /bin/false -c "SickRage daemon user" -d $SR_DATA -g sickrage sickrage &> /dev/null
else
- useradd -s /bin/false -c "SickRage daemon user" -d $SB_DATA -g sickrage -r sickrage &> /dev/null
+ useradd -s /bin/false -c "SickRage daemon user" -d $SR_DATA -g sickrage -r sickrage &> /dev/null
fi
chown -R sickrage:sickrage /opt/sickrage