summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e6790c01601
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = signon-ui-webengine
+ pkgdesc = "webengine" branch of signon-ui for issue #1
+ pkgver = 0.17
+ pkgrel = 0
+ url = https://launchpad.net/online-accounts-signon-ui
+ arch = x86_64
+ license = GPL
+ depends = libaccounts-qt
+ depends = qt5-webkit
+ depends = signon
+ depends = libnotify
+ provides = signon-ui
+ conflicts = signon-ui
+ source = git+https://gitlab.com/accounts-sso/signon-ui.git
+ md5sums = SKIP
+
+pkgname = signon-ui-webengine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4ecdd77cf5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: edward-p <micro dot fedora at gmail dot com>
+
+pkgname=signon-ui-webengine
+pkgver=0.17
+pkgrel=0
+pkgdesc='"webengine" branch of signon-ui for issue #1'
+arch=('x86_64')
+url="https://launchpad.net/online-accounts-signon-ui"
+license=('GPL')
+conflicts=(signon-ui)
+depends=('libaccounts-qt' 'qt5-webkit' 'signon' 'libnotify')
+provides=('signon-ui')
+source=(git+https://gitlab.com/accounts-sso/signon-ui.git)
+md5sums=('SKIP')
+
+prepare() {
+ cd $srcdir/signon-ui
+ git checkout -b webengine origin/webengine
+ # Do not install tests
+ echo 'INSTALLS =' >>tests/unit/tst_inactivity_timer.pro
+ echo 'INSTALLS =' >>tests/unit/tst_signon_ui.pro
+}
+
+build() {
+ cd $srcdir/signon-ui
+
+ qmake PREFIX=/usr LIBDIR=/usr/lib
+ make
+}
+
+package() {
+ cd $srcdir/signon-ui
+
+ make INSTALL_ROOT="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: