summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--frameworks_path.patch4
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dc81ccf5f26..24b4ef2b4455 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = silice-git
pkgdesc = An open source language that simplifies prototyping and writing algorithms on FPGA architectures.
pkgver = 3d12246b
- pkgrel = 7
+ pkgrel = 8
url = https://github.com/sylefeb/Silice
arch = i686
arch = x86_64
@@ -26,6 +26,6 @@ pkgbase = silice-git
source = Silice::git+https://github.com/sylefeb/Silice.git
source = frameworks_path.patch
sha512sums = SKIP
- sha512sums = 4a8f13b488fe114a1d3fe69868883874c5a3e6a04958482e8c964b4ae01b1f9afb416e21645a43cdabe52d7e630285af916280a4181e254bc8be4797ead4cec6
+ sha512sums = faea4abdb6df04b7e4b0ac8a80a71f301e20085e3e9e1823b6b6d3f4ffc8a4d2d84ea077666799ce087ea2c341459a358d90c5e01c7bc6848ee5f042d66274a7
pkgname = silice-git
diff --git a/PKGBUILD b/PKGBUILD
index 01d50712557a..5802ed708685 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=silice-git
_pkgname=Silice
pkgver=3d12246b
-pkgrel=7
+pkgrel=8
pkgdesc="An open source language that simplifies prototyping and writing algorithms on FPGA architectures."
arch=('i686' 'x86_64' 'armv7h' 'armv8' 'riscv64')
url="https://github.com/sylefeb/Silice"
@@ -14,7 +14,7 @@ provides=("silice")
source=("${_pkgname}::git+https://github.com/sylefeb/${_pkgname}.git"
frameworks_path.patch)
sha512sums=('SKIP'
- '4a8f13b488fe114a1d3fe69868883874c5a3e6a04958482e8c964b4ae01b1f9afb416e21645a43cdabe52d7e630285af916280a4181e254bc8be4797ead4cec6')
+ 'faea4abdb6df04b7e4b0ac8a80a71f301e20085e3e9e1823b6b6d3f4ffc8a4d2d84ea077666799ce087ea2c341459a358d90c5e01c7bc6848ee5f042d66274a7')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -24,7 +24,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
git submodule update --init --recursive
- patch -Np1 -i ${srcdir}/frameworks_path.patch
+ #patch -Np1 -i ${srcdir}/frameworks_path.patch
}
build() {
diff --git a/frameworks_path.patch b/frameworks_path.patch
index 716689244134..3ed77ff204d8 100644
--- a/frameworks_path.patch
+++ b/frameworks_path.patch
@@ -1,5 +1,5 @@
diff --git a/bin/silice-make.py b/bin/silice-make.py
-index cb09ab78..74bf49fd 100755
+index cb09ab78..b7143d4f 100755
--- a/bin/silice-make.py
+++ b/bin/silice-make.py
@@ -75,7 +75,7 @@ except FileExistsError:
@@ -7,7 +7,7 @@ index cb09ab78..74bf49fd 100755
# - frameworks directory
-frameworks_dir = os.path.realpath(os.path.join(make_dir,"../frameworks/"))
-+frameworks_dir = "/usr/share/silice/frameworks/"))
++frameworks_dir = "/usr/share/silice/frameworks/"
if args.root:
frameworks_dir = os.path.realpath(os.path.abspath(args.root))
print("* Silice frameworks directory: ",frameworks_dir,"\t\t\t",end='')