summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 8 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70eda435cb10..89127af34796 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = simbody
pkgdesc = High-performance C++ multibody dynamics/physics library for simulating articulated biomechanical and mechanical systems like vehicles, robots, and the human skeleton.
- pkgver = 3.6.1
- pkgrel = 3
+ pkgver = 3.7
+ pkgrel = 1
url = https://simtk.org/home/simbody
arch = i686
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = simbody
optdepends = libxi
optdepends = libxmu
optdepends = doxygen
- source = https://github.com/simbody/simbody/archive/Simbody-3.6.1.tar.gz
- sha256sums = 7716d6ea20b950e71e8535faa4353ac89716c03fd7a445dd802eb6a630796639
+ source = https://github.com/simbody/simbody/archive/Simbody-3.7.tar.gz
+ sha256sums = d371a92d440991400cb8e8e2473277a75307abb916e5aabc14194bea841b804a
pkgname = simbody
diff --git a/PKGBUILD b/PKGBUILD
index d09e018c207b..2c7c5cb1c3b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Previous Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Contributo: Benjamin Chretien <chretien at lirmm dot fr>
pkgname=simbody
-pkgver=3.6.1
-pkgrel=3
+pkgver=3.7
+pkgrel=1
pkgdesc="High-performance C++ multibody dynamics/physics library for simulating articulated biomechanical and mechanical systems like vehicles, robots, and the human skeleton."
arch=('i686' 'x86_64')
url="https://simtk.org/home/simbody"
@@ -10,46 +10,26 @@ license=('Apache')
depends=('lapack' 'blas')
optdepends=('freeglut' 'libxi' 'libxmu' 'doxygen')
makedepends=('cmake')
-provides=()
-conflicts=()
_dir="${pkgname}-Simbody-${pkgver}"
source=("https://github.com/simbody/${pkgname}/archive/Simbody-${pkgver}.tar.gz")
-sha256sums=('7716d6ea20b950e71e8535faa4353ac89716c03fd7a445dd802eb6a630796639')
-
-_buildtype="Release"
+sha256sums=('d371a92d440991400cb8e8e2473277a75307abb916e5aabc14194bea841b804a')
build() {
-
- cd "${srcdir}/${_dir}"
-
- msg "Starting CMake (build type: ${_buildtype})"
-
# Create a build directory
mkdir -p "${srcdir}/${_dir}/build"
cd "${srcdir}/${_dir}/build"
# Build project
cmake \
- -DCMAKE_BUILD_TYPE="${_buildtype}" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
"${srcdir}/${_dir}"
-
- msg "Building the project"
make
}
-#check() {
-# cd "${srcdir}/${_dir}/build"
-# make test
-#}
-
package() {
-
cd "${srcdir}/${_dir}/build"
-
- msg "Installing files"
make DESTDIR="${pkgdir}/" install
}