summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD25
2 files changed, 11 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4b9c5b49da3..b5516de240c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = simpletools
pkgdesc = Handy command line tools for ntuple manipulation and analysis
- pkgver = 2.0v.8e38d80
+ pkgver = 3.0
pkgrel = 1
url = https://github.com/cofitzpa/simpletools
arch = i686
@@ -10,7 +10,7 @@ pkgbase = simpletools
makedepends = git
depends = boost
depends = root
- source = simpletools::git+https://github.com/cofitzpa/simpletools#commit=8e38d80
+ source = simpletools-3.0.tar.gz::https://github.com/cofitzpa/simpletools/archive/v3.0.tar.gz
source = settings.cmake
sha256sums = SKIP
sha256sums = 540b86cd9997926026a5d277c819ae9c348bde7921158a78f3c676c855b6ab5e
diff --git a/PKGBUILD b/PKGBUILD
index 058757cbbc89..40d06077ebbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Konstantin Gizdov < arch at kge dot pw >
pkgname=simpletools
-_commit=8e38d80
-pkgver=2.0v.${_commit}
+pkgver=3.0
pkgrel=1
pkgdesc="Handy command line tools for ntuple manipulation and analysis"
arch=('i686' 'x86_64')
@@ -10,39 +9,33 @@ url="https://github.com/cofitzpa/simpletools"
license=('GPL2')
makedepends=('cmake' 'git')
depends=('boost' 'root')
-source=("${pkgname}::git+https://github.com/cofitzpa/simpletools#commit=${_commit}"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cofitzpa/simpletools/archive/v${pkgver}.tar.gz"
'settings.cmake')
sha256sums=('SKIP'
'540b86cd9997926026a5d277c819ae9c348bde7921158a78f3c676c855b6ab5e')
-
-prepare() {
- mkdir -p "${srcdir}/${pkgname}/build"
- cd "${srcdir}/${pkgname}/build"
-
+build() {
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
CFLAGS="${CFLAGS}" \
CXXFLAGS="${CXXFLAGS}" \
LDFLAGS="${LDFLAGS}" \
- cmake -C "${srcdir}/settings.cmake" "${srcdir}/${pkgname}"
-}
-
-build() {
- cd "${srcdir}/${pkgname}/build"
+ cmake -C "${srcdir}/settings.cmake" "${srcdir}/${pkgname}-${pkgver}"
make
}
package() {
- cd "${srcdir}/${pkgname}/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}" install
# install tutorials
install -d "${pkgdir}/usr/share/simpletools/tutorial/"
declare -a tutorials
- tutorials=("${srcdir}/${pkgname}"/simpletools_tutorial/*)
+ tutorials=("${srcdir}/${pkgname}-${pkgver}"/simpletools_tutorial/*)
for tutorial in "${tutorials[@]}"; do
install -Dm644 "${tutorial}" "${pkgdir}/usr/share/simpletools/tutorial/"
done
# install docs & license
- install -Dm644 "${srcdir}/${pkgname}/README.md" "${pkgdir}/usr/share/doc/simpletools/README.md"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/README.md" "${pkgdir}/usr/share/doc/simpletools/README.md"
}