summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 794880a50959..4bd57ba1dd0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,6 @@ conflicts=('')
license=('GPL')
depends=('ncurses' 'boost' 'boost-libs')
options=(buildflags)
-# Required setting of explicit standard for g++, otherwise libboost template handling will break after g++ 6
-buildflags=('"CXXFLAGS="')
source=(http://www.ant.uni-bremen.de/whomes/rinas/sinfo/download/$pkgname-$pkgver.tar.gz sinfod.service)
url="http://www.ant.uni-bremen.de/whomes/rinas/sinfo/"
#
@@ -22,6 +20,7 @@ build() {
sed -i 's/\-mt//g' sinfo/Makefile.*
sed -i 's/\-mt//g' sinfod/Makefile.*
./configure --prefix=/usr --sbindir=/usr/bin
+# Required setting of explicit standard for g++, otherwise libboost template handling will break after g++ 6
make CXXFLAGS="-std=c++98"
}