summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--sitracker.install41
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d503e730f4bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sitracker
+ pkgdesc = Support Incident Tracker (or SiT!) is a web based helpdesk/support ticket system
+ pkgver = 3.67
+ pkgrel = 1
+ url = http://www.sitracker.org/
+ install = sitracker.install
+ arch = any
+ license = GPL
+ depends = php
+ source = http://downloads.sourceforge.net/project/sitracker/stable/3.67/sit_3.67p2.tar.gz
+ md5sums = 27531cc0647236fbd2e2dce52fc9b598
+
+pkgname = sitracker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4cab5aa4df2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: realitygaps <realitygaps AT yahoo DOT com>
+# Maintainer: realitygaps <realitygaps AT yahoo DOT com>
+
+pkgname=sitracker
+_pkgrealname=sit
+pkgver=3.67
+_pkgrealver=3.67p2
+
+pkgrel=1
+pkgdesc="Support Incident Tracker (or SiT!) is a web based helpdesk/support ticket system"
+arch=('any')
+url="http://www.sitracker.org/"
+license=('GPL')
+depends=('php')
+install=${pkgname}.install
+source=(http://downloads.sourceforge.net/project/${pkgname}/stable/${pkgver}/${_pkgrealname}_${_pkgrealver}.tar.gz)
+md5sums=('27531cc0647236fbd2e2dce52fc9b598')
+build() {
+ mkdir -p $pkgdir/srv/http/sitracker
+ cp -r $srcdir/${_pkgrealname}-${pkgver}/* $pkgdir/srv/http/sitracker/
+}
+
+
+
diff --git a/sitracker.install b/sitracker.install
new file mode 100644
index 000000000000..ad54f1ebd6c0
--- /dev/null
+++ b/sitracker.install
@@ -0,0 +1,41 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ echo "Remember that you need to install either mysql or postgresql for this package to work"
+ if [[ ! `grep "^extension=mysql.so" /etc/php/php.ini` ]]
+ then echo "If you use mysql you should enable its module by adding the line:"
+ echo " extension=mysql.so"
+ echo "to your /etc/php/php.ini, otherwise SiTracker won't work."
+ fi
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+