summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--sk-boot-to-windows.sh2
3 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18164f1176d8..8bf52d9e809e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sk-boot-to-windows
pkgdesc = Creates a .desktop application to boot into Windows
- pkgver = 1.0.3
+ pkgver = 1.0.4
pkgrel = 1
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 393fa8764a7d..d3e974d36572 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname="sk-boot-to-windows"
-pkgver="1.0.3"
+pkgver="1.0.4"
pkgrel=1
pkgdesc="Creates a .desktop application to boot into Windows"
arch=(any)
diff --git a/sk-boot-to-windows.sh b/sk-boot-to-windows.sh
index 3ed06d5e777c..b6270af146b6 100644
--- a/sk-boot-to-windows.sh
+++ b/sk-boot-to-windows.sh
@@ -4,7 +4,7 @@
boot_list=$(efibootmgr)
# 使用 grep 命令查找包含 "Windows Boot Manager" 的启动项行,并提取其编号
-boot_entry=$(echo "$boot_list" | grep -i "Windows Boot Manager" | grep -i "bootmgfw.efi" | awk '{print $1}') | head -n 1
+boot_entry=$(echo "$boot_list" | grep -i "Windows Boot Manager" | grep -i "bootmgfw.efi" | awk '{print $1}' | head -n 1)
# 去掉启动项编号中的前缀 "Boot" 和后面的星号 "*",只保留编号部分
boot_entry=${boot_entry#Boot}