summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5816c38624d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Apr 2 19:53:14 UTC 2018
+pkgbase = skeema-git
+ pkgdesc = A tool for managing MySQL tables and schema changes
+ pkgver = r147.4930f00
+ pkgrel = 1
+ url = https://github.com/skeema/skeema
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = go
+ provides = skeema
+ conflicts = skeema
+ conflicts = skeema-git
+ options = !strip
+ source = git+https://github.com/skeema/skeema.git
+ sha256sums = SKIP
+
+pkgname = skeema-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..480cabeb0243
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Victor Häggqvist <aur a snilius d com>
+# https://github.com/victorhaggqvist/archlinux-pkgbuilds
+pkgname=skeema-git
+_pkgname=skeema
+pkgver=r147.4930f00
+pkgrel=1
+pkgdesc="A tool for managing MySQL tables and schema changes"
+arch=(x86_64)
+url="https://github.com/skeema/skeema"
+license=(Apache)
+
+source=("git+https://github.com/skeema/skeema.git")
+sha256sums=('SKIP')
+
+makedepends=(git go)
+provides=(skeema)
+conflicts=(skeema skeema-git)
+options=('!strip')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p "gopath/src/github.com/skeema"
+ export GOPATH=$PWD/gopath
+ mv $_pkgname gopath/src/github.com/skeema
+
+ go install -v github.com/skeema/skeema
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+
+ cp $srcdir/gopath/bin/$_pkgname $pkgdir/usr/bin
+}