summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c093c87db26c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sman
+ pkgdesc = Utility for selecting manpage section to be opened
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/jtojnar/sman
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = cargo
+ depends = ncurses
+ source = https://github.com/jtojnar/sman/archive/v0.1.0/sman-0.1.0.tar.gz
+ sha256sums = 2003ad848c1c783736332f6cf4930083ae920c988f9a041034bfe6522c058036
+
+pkgname = sman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cfb3ab8f543
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jan Tojnar <jtojnar@gmail.com>
+pkgname=sman
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Utility for selecting manpage section to be opened'
+url='https://github.com/jtojnar/sman'
+depends=('ncurses')
+makedepends=('cargo')
+license=('MIT')
+source=("https://github.com/jtojnar/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('2003ad848c1c783736332f6cf4930083ae920c988f9a041034bfe6522c058036')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}