summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf11cb09e1c8..827b62092e2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = snapper-snapshot-notification-git
pkgdesc = The Desktop notification will appear when booting into Btrfs snapshot using Overlayfs.
- pkgver = 1.0.0
+ pkgver = r4.94a129c
pkgrel = 1
url = https://gitlab.com/Zesko/snapper-snapshot-notification.git
arch = any
- license = MIT
+ license = GPL3
makedepends = git
- makedepends = libnotify
+ depends = bash
+ depends = libnotify
provides = snapper-snapshot-notification
+ conflicts = snapper-snapshot-notification
source = git+https://gitlab.com/Zesko/snapper-snapshot-notification.git
- sha256sums = SKIP
+ sha1sums = SKIP
pkgname = snapper-snapshot-notification-git
diff --git a/PKGBUILD b/PKGBUILD
index c7a9a95044ed..3094eba7de68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-_pkgname=snapper-snapshot-notification
-pkgname="${_pkgname}-git"
-pkgver=1.0.0
+# Maintainer: Zesko
+pkgname=snapper-snapshot-notification-git
+pkgver=r4.94a129c
pkgrel=1
pkgdesc="The Desktop notification will appear when booting into Btrfs snapshot using Overlayfs."
arch=("any")
-url="https://gitlab.com/Zesko/${_pkgname}.git"
+url="https://gitlab.com/Zesko/snapper-snapshot-notification.git"
license=("GPL3")
-makedepends=('git' 'libnotify')
-provides=("snapper-snapshot-notification")
+depends=('bash' 'libnotify')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=(git+${url})
-sha256sums=("SKIP")
+sha1sums=("SKIP")
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- install -dv "${pkgdir}/usr/bin"
- install -dv "${pkgdir}/etc/xdg/autostart"
- cd "$srcdir/$_pkgname"
- cp usr/bin/snapper-detects-snapshot $pkgdir/usr/bin/
- cp etc/xdg/autostart/snapper-detects-snapshot.desktop $pkgdir/etc/xdg/autostart/
+ cd "$srcdir/${pkgname%-git}"
+ cp -vr usr etc "$pkgdir"
}