summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38d1784d530a..0db7cdeed2ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = sndcut
pkgdesc = Let's you generated LPs that you can laser cut from audio files. sndcut is a program the generates LP records from audio files - it generates a SVG file that you can laser cut.
- pkgver = 1.0
- pkgrel = 2
+ pkgver = 1.9
+ pkgrel = 1
url = https://github.com/kallaballa/sndcut
arch = x86
arch = x86_64
license = GPL2
makedepends = boost
+ makedepends = cmake
depends = libsndfile
depends = libsamplerate
depends = boost-libs
- source = https://github.com/kallaballa/sndcut/archive/v1.0.zip
- sha1sums = 104e2d75537df3122564b63ca9387e090891e2a7
+ source = https://github.com/kallaballa/sndcut/archive/v1.9.zip
+ sha1sums = b9f9346aaab40b3dbf37a5c056c2109163f4fbc1
pkgname = sndcut
-
diff --git a/PKGBUILD b/PKGBUILD
index 9f6673053e52..ad011a180b4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Florian Schweikert <aur@ist-total.org>
pkgname=sndcut
-pkgver=1.0
-pkgrel=2
+pkgver=1.9
+pkgrel=1
pkgdesc="Let's you generated LPs that you can laser cut from audio files.
sndcut is a program the generates LP records from audio files - it generates a SVG file that you can laser cut."
arch=('x86' 'x86_64')
url="https://github.com/kallaballa/sndcut"
license=('GPL2')
depends=('libsndfile' 'libsamplerate' 'boost-libs')
-makedepends=('boost')
+makedepends=('boost' 'cmake')
source=(https://github.com/kallaballa/$pkgname/archive/v$pkgver.zip)
-sha1sums=('104e2d75537df3122564b63ca9387e090891e2a7')
+sha1sums=('b9f9346aaab40b3dbf37a5c056c2109163f4fbc1')
build() {
cd $pkgname-$pkgver
+ ./build_deps.sh
make
}