summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14dff01bab8c..31bd6537b3da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = softsusy
pkgdesc = This program provides a SUSY spectrum in the NMSSM, or the MSSM including flavour violation and with or without R-parity consistent with input Standard Model fermion mass/mixings and electroweak/strong coupling data.
- pkgver = 4.1.13
+ pkgver = 4.1.20
pkgrel = 1
- url = http://softsusy.hepforge.org
+ url = https://ballanach.github.io/softsusy/
arch = x86_64
license = GPL
makedepends = autoconf
depends = gcc-libs
depends = gcc-fortran
- source = http://www.hepforge.org/archive/softsusy/softsusy-4.1.13.tar.gz
+ source = https://raw.githubusercontent.com/BAllanach/softsusy/master/tags/softsusy-4.1.20.tar.gz
source = remove_duplicate_header.patch
source = remove_install_data_local.patch
- sha256sums = c80c02f15700c793e6d744e02b76adedcbc0d295c6622dd104473ba9ace2833e
+ sha256sums = 3244ae3db8b2309ebabbdfd88e9b3e4760d02b68ee011fb7710b3d9198be74e4
sha256sums = 363e0537caf14b340d1d1308f768e314f0b14a90455c4ba4eaa2fd41884c369b
sha256sums = 5a58edaa0a73a594d7f9758135f0ce10e7cb01c2d6f2a1b08b37237fc5b12263
diff --git a/PKGBUILD b/PKGBUILD
index d0fa8434128b..002fe50c2999 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Chan Beom Park <cbpark@gmail.com>
pkgname=softsusy
-pkgver=4.1.13
+pkgver=4.1.20
pkgrel=1
pkgdesc="This program provides a SUSY spectrum in the NMSSM, or the MSSM including flavour violation and with or without R-parity consistent with input Standard Model fermion mass/mixings and electroweak/strong coupling data."
arch=("x86_64")
-url="http://softsusy.hepforge.org"
+url="https://ballanach.github.io/softsusy/"
license=('GPL')
makedepends=("autoconf")
depends=("gcc-libs" "gcc-fortran")
-source=("http://www.hepforge.org/archive/softsusy/${pkgname}-${pkgver}.tar.gz"
+source=("https://raw.githubusercontent.com/BAllanach/softsusy/master/tags/${pkgname}-${pkgver}.tar.gz"
"remove_duplicate_header.patch"
"remove_install_data_local.patch")
-sha256sums=('c80c02f15700c793e6d744e02b76adedcbc0d295c6622dd104473ba9ace2833e'
+sha256sums=('3244ae3db8b2309ebabbdfd88e9b3e4760d02b68ee011fb7710b3d9198be74e4'
'363e0537caf14b340d1d1308f768e314f0b14a90455c4ba4eaa2fd41884c369b'
'5a58edaa0a73a594d7f9758135f0ce10e7cb01c2d6f2a1b08b37237fc5b12263')
prepare() {
- cd "${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 -i "${srcdir}/remove_duplicate_header.patch"
patch -p1 -i "${srcdir}/remove_install_data_local.patch"
@@ -25,7 +25,7 @@ prepare() {
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr \
--enable-shared=yes \
@@ -34,8 +34,6 @@ build() {
}
package() {
- cd "${pkgname}-${pkgver}"
-
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
- install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}