summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--compilation_fixes.patch (renamed from FullDTW.h.patch)10
3 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8edf69a6e64c..34bd12843b78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sonic-lineup
pkgdesc = Sonic Lineup is a free, open-source application for Windows, Linux, and Mac, designed for rapid visualisation of multiple audio files containing versions of the same source material
pkgver = 1.1
- pkgrel = 4
+ pkgrel = 5
url = https://www.sonicvisualiser.org/sonic-lineup/
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 807789ecec15..ab561c0a6cd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
DLAGENTS=("https::/usr/bin/curl -k -o %o %u")
pkgname=sonic-lineup
pkgver=1.1
-pkgrel=4
+pkgrel=5
pkgdesc="Sonic Lineup is a free, open-source application for Windows, Linux, and Mac, designed for rapid visualisation of multiple audio files containing versions of the same source material"
arch=('x86_64')
url="https://www.sonicvisualiser.org/sonic-lineup/"
@@ -43,7 +43,7 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
export INSTALL_ROOT="${pkgdir}/"
./configure --prefix=/usr
- patch match/src/FullDTW.h ../../FullDTW.h.patch
+ patch -p2 -i ../../compilation_fixes.patch
make
}
diff --git a/FullDTW.h.patch b/compilation_fixes.patch
index 9d087fb09452..a3dad66ce6d6 100644
--- a/FullDTW.h.patch
+++ b/compilation_fixes.patch
@@ -9,3 +9,13 @@
const featureseq_t &s2);
private:
+--- src/sonic-lineup-1.1/svcore/data/model/RelativelyFineZoomConstraint.cpp 2020-08-18 18:20:29.000000000 +0200
++++ RelativelyFineZommConstraint.cpp 2022-08-15 20:46:07.519644306 +0200
+@@ -17,6 +17,7 @@
+ #include <vector>
+ #include <algorithm>
+ #include <iostream>
++#include <utility>
+
+ using namespace std;
+