summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
-rw-r--r--soulseekqt.desktop8
-rw-r--r--soulseekqt.pngbin0 -> 17116 bytes
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08182e849dd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = soulseekqt
+ pkgdesc = A desktop client for the Soulseek peer-to-peer file sharing network
+ pkgver = 20141130
+ pkgrel = 1
+ url = http://www.soulseekqt.net/news/
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = http://www.soulseekqt.net/SoulseekQT/Linux/SoulseekQt-2014-11-30-32bit.tgz
+ source = soulseekqt.desktop
+ source = soulseekqt.png
+
+pkgname = soulseekqt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc11cdf55ada
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: M0Rf30
+# Contributor: said
+# Contributor: Ner0
+# Contributor: farnsworth517
+
+pkgname=soulseekqt
+pkgver=20141130
+_pkgver=2014-11-30
+
+if [[ "$CARCH" == 'x86_64' ]] ; then
+ _pkgver=$_pkgver-64bit
+else
+ _pkgver=$_pkgver-32bit
+fi
+
+pkgrel=1
+pkgdesc="A desktop client for the Soulseek peer-to-peer file sharing network"
+arch=('i686' 'x86_64')
+url="http://www.soulseekqt.net/news/"
+license=('custom')
+
+if [[ "$CARCH" == 'i686' ]] ; then
+ depends=( 'libxext' 'fontconfig' 'libxrender' 'libsm' 'alsa-lib' )
+ md5sums=( '0ce2ebf13704574205cc4c47368fb14b'
+ '0a2137a47e9ac0b4b57a0d55872d0842'
+ '256ec24f7ad2d39ac8da0f1c03d3cafe' )
+elif [[ "$CARCH" == 'x86_64' ]] ; then
+ depends=( 'libxext' 'fontconfig' 'libxrender' )
+ md5sums=( '8f644c5903d11233ebb3c65a4eafaeb6'
+ '0a2137a47e9ac0b4b57a0d55872d0842'
+ '256ec24f7ad2d39ac8da0f1c03d3cafe' )
+fi
+
+source=( "http://www.soulseekqt.net/SoulseekQT/Linux/SoulseekQt-$_pkgver.tgz"
+ $pkgname.desktop
+ $pkgname.png )
+
+package() {
+ install -vDm755 "$srcdir/SoulseekQt-$_pkgver" "$pkgdir/usr/bin/$pkgname"
+ install -vDm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -vDm644 "$srcdir/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
diff --git a/soulseekqt.desktop b/soulseekqt.desktop
new file mode 100644
index 000000000000..f3772b6e329b
--- /dev/null
+++ b/soulseekqt.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=SoulSeekQT
+Exec=soulseekqt
+Icon=soulseekqt
+Terminal=false
+Type=Application
+Categories=Network;P2P;
+Comment=Soulseek music-sharing client
diff --git a/soulseekqt.png b/soulseekqt.png
new file mode 100644
index 000000000000..d36943e239de
--- /dev/null
+++ b/soulseekqt.png
Binary files differ