summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7223b536ae30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Aug 30 07:19:34 UTC 2017
+pkgbase = soundpipe-dev
+ pkgdesc = Lightweight music DSP library
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://paulbatchelor.github.io/proj/soundpipe.html
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = libsndfile
+ makedepends = git
+ source = git+https://github.com/PaulBatchelor/Soundpipe#commit=3946d5b77f8e2e812b919d547518b896b1439554
+ md5sums = SKIP
+
+pkgname = soundpipe-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6b037e4a954
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Teteros <teteros@openmailbox.org>
+
+pkgname=soundpipe-dev
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='Lightweight music DSP library'
+arch=('x86_64' 'i686')
+url='http://paulbatchelor.github.io/proj/soundpipe.html'
+license=('MIT')
+makedepends=('libsndfile' 'git')
+source=("git+https://github.com/PaulBatchelor/Soundpipe#commit=3946d5b77f8e2e812b919d547518b896b1439554")
+md5sums=('SKIP')
+
+build() {
+ make -C Soundpipe
+}
+
+package() {
+ PREFIX="$pkgdir/usr" make -C Soundpipe install -e
+ install -Dm644 Soundpipe/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:ts=2 sw=2 et: