summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rwxr-xr-xsetup.sh65
3 files changed, 3 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 449318cfb489..c065f889217b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = sourcery-codebench-arm-none-linux-gnueabi
- pkgdesc = Sourcery CodeBench Lite for ARM EABI
+ pkgdesc = Sourcery CodeBench Lite for ARM NONE LINUX GNUEABI
pkgver = 2014.05
pkgrel = 1
url = http://www.mentor.com/embedded-software/sourcery-tools/sourcery-codebench/editions/lite-edition/
diff --git a/PKGBUILD b/PKGBUILD
index 7562169ac93b..09672ae02730 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=sourcery-codebench-arm-none-linux-gnueabi
pkgver=2014.05
_pkgnum=29
pkgrel=1
-pkgdesc="Sourcery CodeBench Lite for ARM EABI"
+pkgdesc="Sourcery CodeBench Lite for ARM NONE LINUX GNUEABI"
arch=('i686' 'x86_64')
url="http://www.mentor.com/embedded-software/sourcery-tools/sourcery-codebench/editions/lite-edition/"
license=('custom')
@@ -21,5 +21,5 @@ package() {
mkdir -p $pkgdir/usr
cp -a * $pkgdir/usr
mkdir -p $pkgdir/usr/share/licenses/arm-none-linux-gnueabi
- cp share/doc/arm-arm-none-linux-gnueabi/LICENSE.txt $pkgdir/usr/share/licenses/arm-none-linux-gnueabi
+ cp share/doc/arm-none-linux-gnueabi/LICENSE.txt $pkgdir/usr/share/licenses/arm-none-linux-gnueabi
}
diff --git a/setup.sh b/setup.sh
deleted file mode 100755
index a5772c20c34c..000000000000
--- a/setup.sh
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/bin/bash
-
-usage()
-{
- cat <<- _EOF_
- Usage: ./setup.sh [OPTIONS] COMMAND...
- Set up infrastructure for tracking PKGBUILDs.
-
- OPTIONS
- -h, --help show this usage message
-
- COMMANDS
- ssh [/path/to/key] add/replace ssh-config rules.
- Key defaults to '~/.ssh/keys/aur'
- hooks link hooks from repo root to
- githooks directory. Must be
- run from repo root.
-_EOF_
-}
-
-ssh() {
- echo "Adding ssh-config rules (this will clear previous rules for 'aur')..."
- sed -ri '/^Host aur(( aur)?.*\.archlinux\.org)?$/,+3d' ~/.ssh/config
- cat <<- _EOF_ >> ~/.ssh/config
- Host aur aur.archlinux.org
- User aur
- Hostname aur.archlinux.org
- IdentityFile ${keypath}
-_EOF_
-}
-
-hooks() {
- echo "Adding commit hooks..."
- shopt -s nullglob
- for hook in *.hook; do
- ln -sf "$(pwd)/${hook}" ".git/hooks/${hook%.hook}"
- done
-}
-
-if [[ $# -eq 0 ]]; then
- echo "error: No arguments passed."
- echo "Try '${0} --help' for more information."
- exit 1
-fi
-while [[ "${1}" != "" ]]; do
- case ${1} in
- -h|--help)
- usage
- exit
- ;;
- ssh)
- shift
- keypath="${1:-~/.ssh/keys/aur}"
- ssh
- ;;
- hooks)
- hooks
- ;;
- *)
- echo "${0}: unrecognized option '${1}'"
- echo "Try '${0} --help' for more information."
- exit 1
- esac
- shift
-done