summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD13
3 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1feb50dbcb3b..6b79924d824b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = sozu-git
pkgdesc = HTTP reverse proxy, configurable at runtime, fast and safe, built in Rust
- pkgver = 0.11.46
- pkgrel = 1
+ pkgver = 0.13.6.r26.g7fb636fe
+ pkgrel = 2
url = https://github.com/sozu-proxy/sozu
arch = i686
arch = x86_64
license = GPL
makedepends = cargo
+ makedepends = git
depends = openssl>=1.0.1
backup = etc/sozu/config.toml
- source = git://github.com/sozu-proxy/sozu
+ source = git+https://github.com/sozu-proxy/sozu
source = config.toml
source = sozu.service
sha1sums = SKIP
@@ -17,4 +18,3 @@ pkgbase = sozu-git
sha1sums = 63fba328c23712d3b83e36187d3016382c3c3a73
pkgname = sozu-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f639cf175581
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!sozu.service
+!config.toml
diff --git a/PKGBUILD b/PKGBUILD
index 52f99e70c426..d40ab9884c58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: Jan-Erik Rediger <badboy at archlinux dot us>
+# Maintainer: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Jan-Erik Rediger <badboy at archlinux dot us>
pkgname=sozu-git
-pkgver=0.11.46
-pkgrel=1
+pkgver=0.13.6.r26.g7fb636fe
+pkgrel=2
pkgdesc="HTTP reverse proxy, configurable at runtime, fast and safe, built in Rust"
arch=('i686' 'x86_64')
url="https://github.com/sozu-proxy/sozu"
license=('GPL')
depends=('openssl>=1.0.1')
-makedepends=('cargo')
+makedepends=('cargo' 'git')
backup=('etc/sozu/config.toml')
source=(
- 'git://github.com/sozu-proxy/sozu'
+ 'git+https://github.com/sozu-proxy/sozu'
'config.toml'
'sozu.service'
)
@@ -59,5 +60,3 @@ package() {
install -Dm644 ../sozu.service "$pkgdir"/usr/lib/systemd/system/sozu.service
}
-
-# vim:set ts=2 sw=2 sts=2 et: