summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD38
-rw-r--r--desktop.install12
-rw-r--r--spacecom.desktop8
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e21981e8366
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = spacecom-hib
+ pkgdesc = a strategic-to-the-bone, starfleet command game in which deception, smart movement, and choices to battle decide victory or defeat
+ pkgver = 0.9.1035
+ pkgrel = 1
+ url = http://www.11bitstudios.com/games/18/spacecom
+ install = desktop.install
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ source = hib://spacecomLinux0.9.1035.zip
+ source = spacecom.desktop
+ md5sums = a89515caa9e79a36b1769fbecc71e3d8
+ md5sums = 9ca589494af9804f2e3c35d6aecbe5db
+ depends_i686 = glu
+ depends_i686 = libxcursor
+ depends_i686 = alsa-lib
+ depends_i686 = gcc-libs
+ optdepends_i686 = alsa-plugins: PulseAudio support
+ depends_x86_64 = lib32-glu
+ depends_x86_64 = lib32-libxcursor
+ depends_x86_64 = lib32-alsa-lib
+ depends_x86_64 = lib32-gcc-libs
+ optdepends_x86_64 = lib32-alsa-plugins: PulseAudio support
+ optdepends_x86_64 = lib32-libpulse: PulseAudio support
+
+pkgname = spacecom-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..286f20a72e36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: XZS <d dot f dot fischer at web dot de>
+
+pkgname=spacecom-hib
+pkgver=0.9.1035
+pkgrel=1
+pkgdesc='a strategic-to-the-bone, starfleet command game in which deception, smart movement, and choices to battle decide victory or defeat'
+url='http://www.11bitstudios.com/games/18/spacecom'
+arch=('i686' 'x86_64')
+license=('custom:commercial')
+depends_i686=('glu' 'libxcursor' 'alsa-lib' 'gcc-libs')
+optdepends_i686=('alsa-plugins: PulseAudio support')
+depends_x86_64=('lib32-glu' 'lib32-libxcursor' 'lib32-alsa-lib' 'lib32-gcc-libs')
+optdepends_x86_64=('lib32-alsa-plugins: PulseAudio support'
+ 'lib32-libpulse: PulseAudio support')
+install=desktop.install
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+source=("hib://spacecomLinux${pkgver}.zip"
+ 'spacecom.desktop')
+md5sums=('a89515caa9e79a36b1769fbecc71e3d8'
+ '9ca589494af9804f2e3c35d6aecbe5db')
+
+build() {
+ cd Linux
+
+ # Fix permissions
+ find SPACECOM_Data -type f -exec chmod 644 {} \;
+ find -type d -exec chmod 755 {} \;
+ chmod 644 'SPACECOM Game Manual.pdf'
+ chmod 755 'SPACECOM.x86'
+}
+
+package() {
+ install -d "$pkgdir"/{opt/spacecom,usr/{bin,share/{pixmaps,applications}}}
+ cp -r Linux/* "$pkgdir/opt/spacecom"
+ install "spacecom.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ ln -s "/opt/spacecom/SPACECOM_Data/Resources/UnityPlayer.png" "$pkgdir/usr/share/pixmaps/spacecom.png"
+ ln -s '/opt/spacecom/SPACECOM.x86' "$pkgdir/usr/bin/spacecom"
+}
diff --git a/desktop.install b/desktop.install
new file mode 100644
index 000000000000..29efd5c2d9cf
--- /dev/null
+++ b/desktop.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_upgrade $1
+}
diff --git a/spacecom.desktop b/spacecom.desktop
new file mode 100644
index 000000000000..84879bc2c720
--- /dev/null
+++ b/spacecom.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories=Game;StrategyGame;
+Name=Spacecom
+Icon=spacecom
+Exec=spacecom
+Terminal=false