summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90d5c908275d..b7fad7d22480 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spacedrive-bin
pkgdesc = A file manager from the future.
- pkgver = 0.1.4
+ pkgver = 0.2.2
pkgrel = 1
epoch = 1
url = https://spacedrive.com
@@ -18,9 +18,10 @@ pkgbase = spacedrive-bin
depends = cairo
depends = gdk-pixbuf2
depends = libheif
+ depends = onnxruntime
provides = spacedrive
conflicts = spacedrive
- source = https://github.com/spacedriveapp/spacedrive/releases/download/0.1.4/Spacedrive-linux-x86_64.deb
- sha256sums = 0188b247893c450d9b51686f702987818497c415215a49db5910ba59c57c07d6
+ source = https://github.com/spacedriveapp/spacedrive/releases/download/0.2.2/Spacedrive-linux-x86_64.deb
+ sha256sums = 3dee73e6f07228dbeb1666ea8720b13eaeb1c946f64a323e6d1dee82d8e217ba
pkgname = spacedrive-bin
diff --git a/PKGBUILD b/PKGBUILD
index fcfbeda61236..eae785440862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Niklas Wojtkowiak <aur.7xcqe@passmail.com>
_pkgname='spacedrive'
pkgname="${_pkgname}-bin"
-pkgver='0.1.4'
+pkgver='0.2.2'
pkgrel='1'
epoch='1'
pkgdesc="A file manager from the future."
@@ -12,13 +12,17 @@ url="https://spacedrive.com"
_url_source='https://github.com/spacedriveapp/spacedrive'
license=('AGPL3')
source=("${_url_source}/releases/download/${pkgver}/Spacedrive-linux-x86_64.deb")
-sha256sums=('0188b247893c450d9b51686f702987818497c415215a49db5910ba59c57c07d6')
-depends=(gtk3 ffmpeg4.4 webkit2gtk openssl-1.1 glibc gcc-libs glib2 pango libsoup cairo gdk-pixbuf2 libheif)
+sha256sums=('3dee73e6f07228dbeb1666ea8720b13eaeb1c946f64a323e6d1dee82d8e217ba')
+depends=(gtk3 ffmpeg4.4 webkit2gtk openssl-1.1 glibc gcc-libs glib2 pango libsoup cairo gdk-pixbuf2 libheif onnxruntime)
provides=(spacedrive)
conflicts=(spacedrive)
package() {
tar -xf "${srcdir}/data.tar.gz" --directory "${srcdir}"
+ #temporary workaround fixes #2006
+ mkdir -p "${pkgdir}/usr/lib/spacedrive/"
+ ln -s "/usr/lib/libonnxruntime.so" "${pkgdir}/usr/lib/spacedrive/libonnxruntime.so"
+
chmod -R 755 "${srcdir}/usr/share/"
install -Dm755 "${srcdir}/usr/bin/spacedrive" "${pkgdir}/usr/bin/spacedrive"
install -dm755 "${pkgdir}/usr/share/"