summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83e6ba5f84c0..8a5f8d26b081 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = sparklines-git
pkgdesc = Spark: Sparklines for your shell
- pkgver = v1.0.1.6.g9832447
+ pkgver = v1.0.1.33.gab88ac6
pkgrel = 1
- url = http://zachholman.com/spark/
+ url = https://zachholman.com/spark/
arch = any
license = MIT
makedepends = git
provides = sparklines
conflicts = sparklines
- source = git://github.com/holman/spark.git
+ source = git+https://github.com/holman/spark.git
sha256sums = SKIP
pkgname = sparklines-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 96c05ede4f56..8a13213136e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
-# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Jerome Leclanche <jerome@leclan.ch>
# NOTE: This package is officially named "spark", however that name
# conflicts with the Spark IM client. It is here renamed sparklines.
_pkgname=spark
pkgname=sparklines-git
-pkgver=v1.0.1.6.g9832447
+pkgver=v1.0.1.33.gab88ac6
pkgrel=1
pkgdesc="Spark: Sparklines for your shell"
arch=("any")
-url="http://zachholman.com/spark/"
+url="https://zachholman.com/spark/"
license=("MIT")
makedepends=("git")
provides=("sparklines")
conflicts=("sparklines")
-source=("git://github.com/holman/$_pkgname.git")
+source=("git+https://github.com/holman/${_pkgname}.git")
sha256sums=("SKIP")
-
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}"
git describe --always | sed "s/-/./g"
}
package() {
- cd "$srcdir/$_pkgname"
- install -D spark "$pkgdir/usr/bin/sparklines"
- install -D "README.md" "$pkgdir/usr/share/doc/spark/README.md"
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname%-git}/README.md"
}