summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..450a2643648a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = specterext-faucet
+ pkgdesc = Specter faucet extention for regtest
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://specter.solutions
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/stepansnigirev/specterext-faucet/archive/refs/tags/v0.1.2.tar.gz
+ sha256sums = 9051633e45595a0cac395c9009445807be4be16913730f12d47472ac377afbb6
+
+pkgname = specterext-faucet
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5dd68eabdae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: bitcoinlizard <bitcoinlizard at fastmail dot com>
+
+pkgname=specterext-faucet
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Specter faucet extention for regtest"
+arch=('any')
+url="https://specter.solutions"
+license=('MIT')
+makedepends=('python-setuptools')
+depends=('python')
+source=("https://github.com/stepansnigirev/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('9051633e45595a0cac395c9009445807be4be16913730f12d47472ac377afbb6')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py sdist bdist_wheel
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ # Install license since the package doesn't include it
+ install -Dm 644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+}