summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af9c7dbce065
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = spell
+ pkgdesc = A clone of the standard Unix program of the same name, implemented as a wrapper for Ispell
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://directory.fsf.org/wiki/Spell
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ source = spell-1.1.tar.gz::https://ftp.gnu.org/gnu/spell/spell-1.1.tar.gz
+ md5sums = c1dc2c4fd30b28d6480279b79a6fb889
+
+pkgname = spell
+ depends = ispell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d4add95a6a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Timothy Brown <sysop@timb.us>
+pkgname=spell
+pkgver=1.1
+pkgrel=1
+pkgdesc="A clone of the standard Unix program of the same name, implemented as a wrapper for Ispell"
+arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://directory.fsf.org/wiki/Spell"
+license=('GPL3')
+source=("$pkgname-$pkgver.tar.gz::https://ftp.gnu.org/gnu/spell/$pkgname-$pkgver.tar.gz")
+md5sums=('c1dc2c4fd30b28d6480279b79a6fb889')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=$pkgdir/usr
+ make
+}
+
+package() {
+ depends=('ispell')
+ cd "$pkgname-$pkgver"
+ /usr/bin/install -d $pkgdir/usr/bin $pkgdir/usr/share/info
+ /usr/bin/install ./spell $pkgdir/usr/bin/spell
+ /usr/bin/install -m 644 ./spell.info $pkgdir/usr/share/info/spell.info
+}