summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ef8c6cdb195..0855fa2dc307 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spirv-cross
pkgdesc = A tool and library for parsing and converting SPIR-V to other shader languages
- pkgver = 1.3.283.0
+ pkgver = 1.3.296.0
pkgrel = 1
epoch = 1
url = https://github.com/KhronosGroup/SPIRV-Cross/
@@ -10,13 +10,13 @@ pkgbase = spirv-cross
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=vulkan-sdk-1.3.283.0
- source = git+https://github.com/KhronosGroup/glslang.git#commit=a7785ea1ff5b10bfc2d8ca77fdad5929562897b7
- source = git+https://github.com/KhronosGroup/SPIRV-Tools.git#commit=afaf8fda2ad0364655909b56c8b634ce89095bb5
- source = git+https://github.com/KhronosGroup/SPIRV-Headers.git#commit=e867c06631767a2d96424cbec530f9ee5e78180f
- sha256sums = 9c2a148a1e4c7ca16ab54991980ed6393c1c21794081083f2779d880b3dbf1d4
- sha256sums = e057bbfcfef5392f7af0fcf034e01b62eb40f66cc3202bb4717e61199a8ce96d
- sha256sums = e1fca43e16eb9b9ea4f1914ab572ca0f66910b96bd8b1069d48dd1e7cdf30352
- sha256sums = 7eab7bb5368f2f841812a5ce10400d5f3301c7ae700512997f2462909b10aeac
+ source = git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=vulkan-sdk-1.3.296.0
+ source = git+https://github.com/KhronosGroup/glslang.git#commit=10ee92feb00712f444783032f5c9ee798887670d
+ source = git+https://github.com/KhronosGroup/SPIRV-Tools.git#commit=fd96922e9a1814d92df46df03277788c799a4fad
+ source = git+https://github.com/KhronosGroup/SPIRV-Headers.git#commit=ea77f2a826bc820cb8f57f9b2a7c7eccb681c73
+ sha256sums = f16fab7bebe6bf43a49a4540cd95adf8f83db72bc6c35141b09e248e0502d5db
+ sha256sums = 7d8f1e6a9b0d46baea671474c15d8cbbbe157a2f43a1940bdf8e0aced315c5d9
+ sha256sums = 38b55d2abc1f351325640e891b862186114e7698204fcf5d693c9264b8239e64
+ sha256sums = 5e46d98e2c53326f11e34a225ddbf8bf17438ba5cf4b046b52fb5f650ec5c532
pkgname = spirv-cross
diff --git a/PKGBUILD b/PKGBUILD
index 6e2d020094da..dabdc7fb631a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=spirv-cross
-pkgver=1.3.283.0
+pkgver=1.3.296.0
pkgrel=1
epoch=1
-_glslang_commit=a7785ea1ff5b10bfc2d8ca77fdad5929562897b7
-_spirv_tools_commit=afaf8fda2ad0364655909b56c8b634ce89095bb5
-_spirv_headers_commit=e867c06631767a2d96424cbec530f9ee5e78180f
+_glslang_commit=10ee92feb00712f444783032f5c9ee798887670d
+_spirv_tools_commit=fd96922e9a1814d92df46df03277788c799a4fad
+_spirv_headers_commit=ea77f2a826bc820cb8f57f9b2a7c7eccb681c73
pkgdesc='A tool and library for parsing and converting SPIR-V to other shader languages'
arch=('x86_64')
url='https://github.com/KhronosGroup/SPIRV-Cross/'
@@ -17,10 +17,10 @@ source=("git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=vulkan-sdk-${pk
"git+https://github.com/KhronosGroup/glslang.git#commit=${_glslang_commit}"
"git+https://github.com/KhronosGroup/SPIRV-Tools.git#commit=${_spirv_tools_commit}"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git#commit=${_spirv_headers_commit}")
-sha256sums=('9c2a148a1e4c7ca16ab54991980ed6393c1c21794081083f2779d880b3dbf1d4'
- 'e057bbfcfef5392f7af0fcf034e01b62eb40f66cc3202bb4717e61199a8ce96d'
- 'e1fca43e16eb9b9ea4f1914ab572ca0f66910b96bd8b1069d48dd1e7cdf30352'
- '7eab7bb5368f2f841812a5ce10400d5f3301c7ae700512997f2462909b10aeac')
+sha256sums=('f16fab7bebe6bf43a49a4540cd95adf8f83db72bc6c35141b09e248e0502d5db'
+ '7d8f1e6a9b0d46baea671474c15d8cbbbe157a2f43a1940bdf8e0aced315c5d9'
+ '38b55d2abc1f351325640e891b862186114e7698204fcf5d693c9264b8239e64'
+ '5e46d98e2c53326f11e34a225ddbf8bf17438ba5cf4b046b52fb5f650ec5c532')
prepare() {
mkdir -p SPIRV-Cross/external/{glslang,spirv-tools}