summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
-rw-r--r--disable-clippy.patch19
3 files changed, 8 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af788d6dd305..594cc37da6ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spot-client-git
pkgdesc = Gtk/Rust native Spotify client - git version
- pkgver = r698.4b1209d
+ pkgver = r838.cbd3140
pkgrel = 2
url = https://github.com/xou816/spot
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = spot-client-git
makedepends = cargo
makedepends = git
makedepends = meson>=0.50.0
+ makedepends = blueprint-compiler
depends = alsa-lib
depends = cairo
depends = glib2
@@ -30,8 +31,6 @@ pkgbase = spot-client-git
conflicts = spot-client
options = !lto
source = spot-client-git::git+https://github.com/xou816/spot
- source = disable-clippy.patch
sha512sums = SKIP
- sha512sums = 1cb0faced2e6801cb994e9af7b81411355837b2efcd9c82b82751508e0bfcc967c50b3d6296bfdb8c017bbf2e7a503a3920d36cb896e44c896c23f5b9e1d13f1
pkgname = spot-client-git
diff --git a/PKGBUILD b/PKGBUILD
index 1aa5909ef3a9..9eda119c3a05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Rayr <https://rayr.ml/LinkInBio>
+# Maintainer: Jeidnx <jeidnx@domainhier.de>
+# Contributor: Rayr <https://rayr.ml/LinkInBio>
# Contributor: Daniel Peukert <daniel@peukert.cc>
# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
_projectname='spot'
pkgname="$_projectname-client-git"
-pkgver='r698.4b1209d'
+pkgver=r838.cbd3140
pkgrel='2'
pkgdesc='Gtk/Rust native Spotify client - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -11,28 +12,17 @@ url="https://github.com/xou816/$_projectname"
license=('MIT')
depends=('alsa-lib' 'cairo' 'glib2' 'glibc' 'graphene' 'gtk4' 'libadwaita' 'libpulse' 'openssl' 'pango' 'clang')
optdepends=('org.freedesktop.secrets')
-makedepends=('cargo' 'git' 'meson>=0.50.0')
+makedepends=('cargo' 'git' 'meson>=0.50.0' 'blueprint-compiler')
checkdepends=('appstream-glib')
provides=("$_projectname-client")
conflicts=("$_projectname-client")
options=('!lto') # build breaks with LTO enabled (https://gitlab.com/dpeukert/pkgbuilds/-/issues/38)
-source=(
- "$pkgname::git+$url"
- 'disable-clippy.patch'
-)
-sha512sums=('SKIP'
- '1cb0faced2e6801cb994e9af7b81411355837b2efcd9c82b82751508e0bfcc967c50b3d6296bfdb8c017bbf2e7a503a3920d36cb896e44c896c23f5b9e1d13f1')
+source=("$pkgname::git+$url")
+sha512sums=('SKIP')
_sourcedirectory="$pkgname"
_builddirectory='build'
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
-
- # Disable clippy tests, as they don't realy make sense for user builds (https://gitlab.com/dpeukert/pkgbuilds/-/issues/37)
- patch --forward -p1 < '../disable-clippy.patch'
-}
-
pkgver() {
cd "$srcdir/$_sourcedirectory/"
echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
diff --git a/disable-clippy.patch b/disable-clippy.patch
deleted file mode 100644
index 25b954400ad3..000000000000
--- a/disable-clippy.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/src/meson.build b/src/meson.build
-index 755d870..fac1b77 100644
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -208,14 +208,3 @@ test('Unit tests',
- ],
- timeout: 180
- )
--
--cargo_clippy = find_program(meson.source_root() / 'build-aux/clippy.sh')
--test('Clippy',
-- cargo_clippy,
-- args: [
-- meson.source_root(),
-- meson.build_root(),
-- get_option('offline') ? 'true' : 'false'
-- ],
-- timeout: 180
--)