summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
-rw-r--r--spotify2
-rw-r--r--spotify.changelog6
-rw-r--r--spotify.install13
5 files changed, 32 insertions, 36 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7861b8d0bffe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.deb
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index f0bd6d26e8d9..f74ed86178b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,46 +2,45 @@
# Contributor: Eothred <yngve.levinsen@gmail.com>
pkgname=spotify
-pkgver=0.9.17.8
-_anotherpkgver=.gd06432d.31-1
+pkgver=1.0.14.124
pkgrel=1
pkgdesc="A proprietary music streaming service"
-arch=('x86_64')
+arch=('x86_64' 'i686')
license=('custom:"Copyright (c) 2006-2010 Spotify Ltd"')
install=spotify.install
url="http://www.spotify.com"
changelog='spotify.changelog'
options=('!strip')
-conflicts=('spotify-beta')
-
-source=("http://repository.spotify.com/pool/non-free/s/${pkgname}/${pkgname}-client-0.9.17_${pkgver}${_anotherpkgver}_amd64.deb"
-'spotify'
-'spotify.protocol'
-)
-md5sums=('69a320368ded33cfcc4e3bb4cc71575c'
-'d443873ef440a6b59d2e3deef64ab74b'
+
+source=('spotify'
+'spotify.protocol')
+md5sums=('3f843269e92d536cefdd2f68df11f248'
'ef25ddc5b6bf8fe1a0d64cbd79e1f7b4')
-depends=("alsa-lib>=1.0.14" "glibc>=2.6" "libxss>=1.2.0" "qt4>=4.5.0" "openssl" "nspr>=4.0" "nspr<5.0" "gconf" "nss" "dbus" "systemd" "libgcrypt15" "gtk2")
+source_x86_64=('http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.14.124.g4dfabc51_amd64.deb')
+md5sums_x86_64=('d9a0f823712be39f89995faef65f4223')
+
+source_i686=('http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.14.122.gf29d9be0_i386.deb')
+md5sums_i686=('826b8d9c263b8f99610a0e16c21b0653')
+
+depends=("alsa-lib>=1.0.14" "gconf" "gtk2" "glib2" "nss" "libsystemd" "libxtst" "libx11" "libxss")
optdepends=('desktop-file-utils: Adds URI support to compatible desktop environments'
'ffmpeg-compat: Adds support for playback of local files'
- 'libnotify: Adds desktop notifications'
)
package() {
cd "${srcdir}"
- tar -xJf data.tar.xz -C "${pkgdir}"
-
- install -d "${pkgdir}/usr/share/"
- mv "${pkgdir}/opt/spotify" "${pkgdir}/usr/share/"
- rm -r "${pkgdir}/opt"
+ tar -xzf data.tar.gz -C "${pkgdir}"
- # Bin Script
- install -Dm755 "${srcdir}/spotify" "${pkgdir}/usr/bin/spotify"
+ install -d "${pkgdir}"/usr/share/applications
+ install -d "${pkgdir}"/usr/share/pixmaps
+ install "${pkgdir}"/usr/share/spotify/spotify.desktop "${pkgdir}"/usr/share/applications/spotify.desktop
+ install "${pkgdir}"/usr/share/spotify/icons/spotify-linux-512.png "${pkgdir}"/usr/share/pixmaps/spotify-client.png
- # Copy license
- install -Dm644 "${pkgdir}/usr/share/doc/${pkgname}-client-0.9.17/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/copyright"
+ # Bin Script
+ rm "${pkgdir}"/usr/bin/spotify
+ install -Dm755 "${srcdir}/spotify" "${pkgdir}/usr/bin/spotify"
# Copy protocol file if KDE is installed
if [ -f /usr/bin/startkde ]; then
diff --git a/spotify b/spotify
index 26590dd7f838..47649c94288c 100644
--- a/spotify
+++ b/spotify
@@ -1,2 +1,2 @@
#!/bin/sh
-/usr/share/spotify/spotify-client/spotify "$@"
+LD_PRELOAD=libcurl.so.3 /usr/share/spotify/spotify "$@"
diff --git a/spotify.changelog b/spotify.changelog
index 6432338b636b..fb66d5f533f9 100644
--- a/spotify.changelog
+++ b/spotify.changelog
@@ -1,3 +1,9 @@
+6th October 2015 (GMT) AWhetter <(firstname) @ awhetter.co.uk>
+ * 1.0.14.124
+ Updated spotify version (.g4dfabc51)
+ .install is now empty due to lack of {un,}register.sh files
+ 32-bit packages are back
+
22nd May 2015 (GMT) Gadget3000 <gadget3000 at msn dot com>
* 0.9.17.8
Updated spotify version (.gd06432d.31-1)
diff --git a/spotify.install b/spotify.install
index f22bca23bf72..e69de29bb2d1 100644
--- a/spotify.install
+++ b/spotify.install
@@ -1,13 +0,0 @@
-post_install() {
- cd /usr/share/spotify/spotify-client
- ./register.sh
-}
-
-post_upgrade() {
- post_install
-}
-
-pre_remove() {
- cd /usr/share/spotify/spotify-client
- ./unregister.sh
-}