summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD33
2 files changed, 24 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b795d2b4ec4..6a68f52ff56b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = srmio
pkgdesc = library + command line tools to access a "Schoberer Rad Messtechnik" PowerControl V, VI and 7 + read/write their files
- pkgver = 0.1.1~git1
- pkgrel = 2
+ pkgver = 0.1.1git1.r6.gb444b87
+ pkgrel = 1
url = http://www.zuto.de/project/srmio/
arch = i686
arch = x86_64
- license = custom: Rainer Clasen
+ license = MIT
makedepends = gcc
makedepends = make
+ makedepends = git
+ makedepends = autoconf
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/rclasen/srmio/archive/refs/tags/v0.1.1git1.tar.gz
- md5sums = 09aaa574e130431b1b943329e9029ff0
+ source = git+https://github.com/rclasen/srmio.git
+ sha256sums = SKIP
pkgname = srmio
diff --git a/PKGBUILD b/PKGBUILD
index ac9895a73966..fa4822db416a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
-# Maintainer: Ammann Max <maximilian.ammann@googlemail.com>
+# Maintainer: Michael Prager <archlinuxaur@michaelprager.de>
+# Contributor: Ammann Max <maximilian.ammann@googlemail.com>
pkgname=srmio
-pkgver=0.1.1~git1
-pkgrel=2
+pkgver=0.1.1git1.r6.gb444b87
+pkgrel=1
pkgdesc="library + command line tools to access a \"Schoberer Rad Messtechnik\" PowerControl V, VI and 7 + read/write their files"
arch=('i686' 'x86_64')
url="http://www.zuto.de/project/srmio/"
-license=('custom: Rainer Clasen')
-makedepends=('gcc' 'make')
+license=('MIT')
+makedepends=('gcc' 'make' 'git' 'autoconf')
depends=()
options=('!strip' '!buildflags' 'staticlibs')
-source=(https://github.com/rclasen/srmio/archive/refs/tags/v0.1.1git1.tar.gz)
-md5sums=('09aaa574e130431b1b943329e9029ff0')
-pkgverstripped=$(echo $pkgver | sed -r 's/~//g')
+source=('git+https://github.com/rclasen/srmio.git')
+sha256sums=('SKIP')
-build() {
- cd "${srcdir}/srmio-$pkgverstripped/"
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
- # resurrect a variable that would have been generated by a now obsolete autoconf macro. Noweverdays this is simply always true.
- export ac_cv_header_time=yes
- # package on github does not ship with pre-generated configuration in contrast to the pacakge that was available on zuto.de
+build() {
+ cd "$pkgname"
sh ./genautomake.sh
-
./configure --prefix=/usr/
- make -j8
+ make
}
package() {
- cd "${srcdir}/srmio-$pkgverstripped/"
+ cd "$pkgname"
make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}