summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD14
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 471bffcd22bd..539c923aebc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = sshrc-git
pkgdesc = Bring your .bashrc, .vimrc, etc. from your local workstation when you ssh into a remote box.
- pkgver = 20140919
+ pkgver = 20200605
pkgrel = 1
- url = https://github.com/Russell91/sshrc
+ url = https://github.com/cdown/sshrc
arch = any
license = MIT
makedepends = git
depends = openssh
- source = git://github.com/Russell91/sshrc.git
+ source = sshrc-git::git+https://github.com/cdown/sshrc.git
md5sums = SKIP
pkgname = sshrc-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..30b403376f5b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src
+sshrc-git/
+*zst
+*xz
diff --git a/PKGBUILD b/PKGBUILD
index 8eef53542a54..72b008bd184c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
# Maintainer: Achilleas Pipinellis <axilleas@archlinux.info>
pkgname=sshrc-git
-pkgver=20140919
+pkgver=20200605
pkgrel=1
pkgdesc="Bring your .bashrc, .vimrc, etc. from your local workstation when you ssh into a remote box."
arch=('any')
-url="https://github.com/Russell91/sshrc"
+url="https://github.com/cdown/sshrc"
license=('MIT')
depends=('openssh')
makedepends=('git')
-source=("git://github.com/Russell91/sshrc.git")
+source=("${pkgname}::git+https://github.com/cdown/sshrc.git")
md5sums=('SKIP')
-_gitname="sshrc"
-
pkgver() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$pkgname"
git log -1 --format="%cd" --date=short | sed 's|-||g'
}
package() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$pkgname"
install -Dm 0755 sshrc "$pkgdir/usr/bin/sshrc"
- install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$_gitname/LICENSE"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}