summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8176a9b7ada5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sss_code-bin
+ pkgdesc = Terminal tool to take screenshots of your code
+ pkgver = 0.1.8
+ pkgrel = 1
+ url = https://github.com/SergioRibera/sss
+ arch = x86_64
+ license = MIT
+ license = Apache-2.0
+ conflicts = sss_code
+ conflicts = sss_code-git
+ source = https://github.com/SergioRibera/sss/releases/download/sss_code/v0.1.8/sss_code-x86_64-unknown-linux-gnu.tar.xz
+ sha256sums = 10000bfe9013d37e727bdc2cb22dc71a0a07e930a2f042af5700a6265d0c2201
+
+pkgname = sss_code-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efa0382f7f29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dandraghas <dandraghas at proton dot me>
+
+pkgname=sss_code-bin
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="Terminal tool to take screenshots of your code"
+url="https://github.com/SergioRibera/sss"
+conflicts=('sss_code' 'sss_code-git')
+license=('MIT' 'Apache-2.0')
+arch=('x86_64')
+
+source=("${url}/releases/download/sss_code/v${pkgver}/sss_code-x86_64-unknown-linux-gnu.tar.xz")
+sha256sums=('10000bfe9013d37e727bdc2cb22dc71a0a07e930a2f042af5700a6265d0c2201')
+
+package() {
+ cd "sss_code-${arch}-unknown-linux-gnu"
+
+ install -Dm755 sss_code "${pkgdir}/usr/bin/sss_code"
+
+ install -Dm644 LICENSE-MIT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
+ install -Dm644 LICENSE-APACHE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-APACHE"
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}