summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa6b678f1f43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = stag-graph-git
+ pkgdesc = streaming bar graphs, for stats and stuff
+ pkgver = 107.76c7b36
+ pkgrel = 1
+ url = https://github.com/seenaburns/stag
+ arch = i686
+ arch = x86_64
+ depends = ncurses
+ provides = stag-graph
+ conflicts = stag-graph
+ conflicts = stag-git
+ source = stag-graph::git+https://github.com/seenaburns/stag
+ sha256sums = SKIP
+
+pkgname = stag-graph-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faae23d06eae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+_name=stag-graph
+pkgname="${_name}-git"
+pkgdesc='streaming bar graphs, for stats and stuff'
+arch=('i686' 'x86_64')
+url='https://github.com/seenaburns/stag'
+pkgver=107.76c7b36
+pkgrel=1
+depends=('ncurses')
+provides=('stag-graph')
+conflicts=('stag-graph' 'stag-git')
+source=("${_name}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver () {
+ cd "${srcdir}/${_name}"
+ printf '%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ cd "${srcdir}/${_name}"
+ make
+}
+
+package () {
+ cd "${srcdir}/${_name}"
+ make DESTDIR="${pkgdir}" PREFIX='/usr' install
+}